zoukankan      html  css  js  c++  java
  • PAT 1007 Maximum Subsequence Sum (最大连续子序列之和)

    Given a sequence of K integers { N1, N2, ..., N**K }. A continuous subsequence is defined to be { N**i, N**i+1, ..., N**j } where 1≤ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    

    Sample Output:

    10 1 4
    

    思路

    最大连续子序列和。这个题会卡一组数据。

    input
    4
    0 0 0 -1
    
    output
    0 0 0
    
    #include <stdio.h>
    #include <iostream>
    #include <stdlib.h>
    #include <vector>
    #include <algorithm>
    #include <map>
    using namespace std;
    int N;
    int v[10000 + 10];
    int s1, e1, s, e;
    int sum = -1;
    
    int main(){
    	//input
    	cin >> N;
    	for(int i = 0; i < N; i++){
    		cin >> v[i];
    	}
    	//init
    	s1 = v[0];
    	e1 = v[0];
    	s = v[0];
    	e = v[N - 1];
    	//compute
    	int b = 0;
    	for(int i = 0; i < N; i++){
    		if(b >= 0){
    			b += v[i];
    			e1 = v[i];
    		}
    		else{
    			b = v[i];
    			e1 = v[i];
    			s1 = v[i];
    		}
    		if(sum < b){
    			s = s1;
    			e = e1;
    			sum = b;
    		}
    	}
    	sum = max(sum, 0);
    	cout << sum << " " << s << " " << e << endl;
    
    	return 0;
    }
    
  • 相关阅读:
    推荐一个不错的在线Linux学习平台(免安装系统)
    C#基本语法知识
    GDI+ 使用LockBits和指针加快处理速度
    C#对图像像素处理的三种方式
    [转]video4linux(v4l)使用摄像头的实例基础教程与体会
    Eclipse Qt开发环境的建立
    c#图像处理基础
    [转]超酷的图像效果
    Qt开发环境的建立
    C++模版全掌握(实例)
  • 原文地址:https://www.cnblogs.com/woxiaosade/p/12319140.html
Copyright © 2011-2022 走看看