zoukankan      html  css  js  c++  java
  • PAT 1037 Magic Coupon

    The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

    For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

    Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains the number of coupons N**C, followed by a line with N**C coupon integers. Then the next line contains the number of products N**P, followed by a line with N**P product values. Here 1≤N**C,N**P≤105, and it is guaranteed that all the numbers will not exceed 230.

    Output Specification:

    For each test case, simply print in a line the maximum amount of money you can get back.

    Sample Input:

    4
    1 2 4 -1
    4
    7 6 -2 -3
    

    Sample Output:

    43
    

    思路

    给你两个序列,两个序列的任意两个元素可以相乘,每个元素只能用一次,求元素乘积 和的最大值。

    我们只要保证同号的从大到小,依次相乘即可。用两个数组分别存储coupon中大于0的部分,和小于0的部分(将其转化为正数)。同样用两个数组存储product的值,将四个数组从大到小排序,四个数组,两两相乘求和即可。

    记得longlong存储

    代码

    #include <stdio.h>
    #include <string>
    #include <stdlib.h>
    #include <iostream>
    #include <vector>
    #include <string.h>
    #include <algorithm>
    #include <cmath>
    #include <map>
    #include <queue>
    #include <stack>
    #include <functional>
    #include <limits.h> 
    using namespace std;
    int cou1[100010];
    int cou2[100010];
    int pro1[100010];
    int pro2[100010];
    bool cmp(int a, int b){
    	return a > b;
    }
    int main() {
    	int N1, N2;
    	long long sum = 0;
    	scanf("%d", &N1);
    	int t = 0, n1 = 0, n2 = 0, n3 = 0, n4 = 0; 
    	for(int i = 0; i < N1; i++){
    		scanf("%d", &t);
    		if(t > 0)			cou1[n1++] = t;
    		else if (t < 0)		cou2[n2++] = -t;
    	}
    	scanf("%d", &N2);
    	for(int i = 0; i < N2; i++){
    		scanf("%d", &t);
    		if(t > 0)			pro1[n3++] = t;
    		else if (t < 0)		pro2[n4++] = -t;
    	}
    	sort(cou1, cou1 + n1, cmp);
    	sort(cou2, cou2 + n2, cmp);
    	sort(pro1, pro1 + n3, cmp);
    	sort(pro2, pro2 + n4, cmp);
    	int i = 0;
    	while(i < n1 && i < n3){
    		sum += cou1[i] * pro1[i];
    		i++;
    	}
    	i = 0;
    	while(i < n2 && i < n4){
    		sum += cou2[i] * pro2[i];
    		i++;
    	}
    	cout << sum << endl;
    	return 0;
    }
    
  • 相关阅读:
    反射
    关于EwebEeditor 不能上传图片问题解决方法
    js去掉前后空格
    园子开张
    使用Python 爬取 京东 ,淘宝。 商品详情页的数据。(避开了反爬虫机制)
    c#对于加密的一点整合 (AES,RSA,MD5,SHA256)
    移动战略调查:应用开发者首选微软Windows
    Surface Pro打包微软精华 今晚在华开售
    Ceph学习全过程 基于N版
    k8s中部署wordpress
  • 原文地址:https://www.cnblogs.com/woxiaosade/p/12482103.html
Copyright © 2011-2022 走看看