zoukankan      html  css  js  c++  java
  • HDU 1068

    Girls and Boys

    Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 13762    Accepted Submission(s): 6468


    Problem Description
    the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

    The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

    the number of students
    the description of each student, in the following format
    student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
    or
    student_identifier:(0)

    The student_identifier is an integer number between 0 and n-1, for n subjects.
    For each given data set, the program should write to standard output a line containing the result.
     
    Sample Input
    7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
     
    Sample Output
    5 2
     
    Source
     

    最大独立集=N-最大匹配数

    不会二分图求最大匹配数的同学点这里

    然后。。。就没了

    #include<bits/stdc++.h>
    using namespace std;
    int n;
    int line[2002][2002];
    int used[100002];
    int girl[100002];
    bool find(int x)
    {
        for(int j=0;j<n;j++)
        {
            if(line[x][j]==1 && used[j]==0)
            {
                used[j]=1;
                if(girl[j]==0 || find(girl[j]))
                {
                    girl[j]=x;
                    return 1;
                }
            }
        }
        return 0;
    }
    int main()
    {
        
        while(~scanf("%d",&n))
        {
            int num,sum,t;
            memset(girl,0,sizeof(girl));
            memset(line,0,sizeof(line));
            for(int i=0;i<n;i++)
            {
                scanf("%d: (%d) ",&num,&sum);
                for(int i=1;i<=sum;i++)
                {
                    scanf("%d",&t);
                    line[num][t]=line[t][num]=1;    
                }
            }
            int all=0;
            for(int i=0;i<n;i++)
            {
                memset(used,0,sizeof(used));
                if(find(i)) all++;
            }
            cout<<n-all/2<<endl;
            
        }
    }
     
  • 相关阅读:
    关于iframe页面里的重定向问题
    iframe跨域解决方案
    sql 查询优化小计
    年轻不能遇见太惊艳的人
    图片上传预览
    脚本
    前端常见跨域解决方案
    react
    react高阶组件
    React + MobX 状态管理入门及实例
  • 原文地址:https://www.cnblogs.com/wpbing/p/9549418.html
Copyright © 2011-2022 走看看