zoukankan      html  css  js  c++  java
  • HDU 1004 Let the Balloon Rise(STL初体验之map)

    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you. 
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    
    
    5 green red blue red red 3 pink orange pink 0
     
    Sample Output
    
    
    red pink

    题目大意:如题

    思路:创建一个map<string, int>, 通过cnt["string"]=int的方法储存值,学习其中关于“找a是否存在,不存在就先让它为0,再加1,存在就直接加一”

    代码如下

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<iostream>
    #include<string>
    #include<set>
    #include<map>
    #include<queue>
    #include<cmath>
    #include<stdlib.h>
    typedef long long ll;
    typedef unsigned long long ull;
    using namespace std;
    const int maxn = 1e5 + 100;
    double eps = 1e-8;
    map<string, int> cnt;
    int main(){
    	int n;
    	while(scanf("%d", &n) && n){
    		cnt.clear();
    		string a;
    		int ans =0;
    		string anss;
    		for(int i = 0; i < n ; i++){
    			cin >> a;
    			if(!cnt.count(a))cnt[a]=0;
    			cnt[a]++;
    			if(cnt[a]>ans){
    				ans =cnt[a];
    				anss = a;
    			}
    		}
    		cout << anss << endl;
    		
    	}
    	
        return 0;
    }


  • 相关阅读:
    Socket_leaks open socket #5024 left in connection
    阿里云 如何减少备份使用量? mysql数据库的完整备份、差异备份、增量备份
    一个正则式引发的血案 贪婪、懒惰与独占
    linux下tmp目录里很多php开头的文件
    后端线上服务监控与报警方案
    架构先行
    数据盘缩容
    文件过滤 批量删除
    mock数据(模拟后台数据)
    如何避免升级 Linux 实例内核后无法启动
  • 原文地址:https://www.cnblogs.com/wrjlinkkkkkk/p/9552004.html
Copyright © 2011-2022 走看看