zoukankan      html  css  js  c++  java
  • poj 1077-Eight(八数码+逆向bfs打表)

    The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 
     1  2  3  4  
    5 6 7 8
    9 10 11 12
    13 14 15 x
    where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 
     1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4  
    5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8
    9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12
    13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x
    r-> d-> r->
    The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 
    Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and  frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 
    In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three  arrangement. 
     

    Input

    You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle 
    1 2 3 
    x 4 6 
    7 5 8 
    is described by this list: 
    1 2 3 x 4 6 7 5 8 
     

    Output

    You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases. 
     

    Sample Input

    2 3 4 1 5 x 7 6 8
     

    Sample Output

    ullddrurdllurdruldr
    解析:八数码问题,这题如果每次从起点搜到终点可能会超时,由于终点都是一样的,所以可以逆向搜索打表,每种状态可以根据数的相对位置对应一个编号(康拓展开)。
    代码如下:
    #include<cstdio>
    #include<cstring>
    #include<string>
    #include<algorithm>
    #include<set>
    #include<map>
    #include<queue>
    #include<vector>
    #include<iterator>
    #include<utility>
    #include<sstream>
    #include<iostream>
    #include<cmath>
    #include<stack>
    using namespace std;
    const int INF=1000000007;
    const double eps=0.00000001;
    int dx[]={-1,0,1,0},dy[]={0,-1,0,1}; //方向数组
    char dir[]={'d','r','u','l'};        //方向数组对应的相反方向的字符,由于是逆向打表
    int fa[363000],fact[10];             //fa[]保存父亲状态的编号,fact[i]=i!
    string ans[363000];                  /对应的打印路径
    int Cul(int n)
    {
        int ret=1;
        for(int st=1;st<=n;st++)  ret*=st;
        return ret;
    }
    int id(int B[])                    //得到编号
    {
        int ret=0;
        for(int i=0;i<9;i++)
        {
            int less=0;
            for(int j=i+1;j<9;j++)  if(B[j]<B[i])  less++;
            ret+=fact[9-1-i]*less;
        }
        return ret;
    }
    bool in(int x,int y){return x>=0&&x<3&&y>=0&&y<3;}   //判断是否在界内
    struct node
    {
        int x,y,ID;                                      //坐标,id值,此时的状态数组
        int A[9];
    };
    int main()
    {
        for(int i=0;i<10;i++)  fact[i]=Cul(i);
        for(int i=0;i<363000;i++)  ans[i].clear();
        node st;
        st.x=2,st.y=2,st.ID=0;
        for(int i=0;i<3;i++)
            for(int j=0;j<3;j++)  st.A[i*3+j]=i*3+j+1;   //终末状态
        memset(fa,-1,sizeof(fa));
        fa[0]=0;
        queue<node> que;
        que.push(st);
        while(!que.empty())
        {
            node now=que.front();  que.pop();
            for(int op=0;op<4;op++)
            {
                node t=now;
                t.x+=dx[op],t.y+=dy[op];
                if(in(t.x,t.y))
                {
                    swap(t.A[now.x*3+now.y],t.A[t.x*3+t.y]);  //交换位置
                    int I=id(t.A);
                    if(fa[I]==-1)                             //没有被访问过
                    {
                        t.ID=I;
                        que.push(t);
                        fa[I]=now.ID;
                        ans[I]=dir[op]+ans[now.ID];          // 得到路径
                    }
                }
            }
        }
        string S;
        while(getline(cin,S))
        {
            int rear[9],cnt=0;
            istringstream out(S);
            string single;
            while(out>>single)
                if(single=="x")  rear[cnt++]=9;
                else  rear[cnt++]=single[0]-'0';
            int I=id(rear);
            if(fa[I]!=-1)  cout<<ans[I]<<endl;
            else  cout<<"unsolvable"<<endl;
        }
        return 0;
    }
    
     
     
  • 相关阅读:
    从远程库克隆(转载)
    添加远程库(转载)
    远程仓库(转载)
    maven+hudson构建集成测试平台
    maven_基本配置
    crawler_基础之_httpclient 访问网络资源
    crawler_jsoup HTML解析器_使用选择器语法来查找元素
    oracle_job 清空冗余数据 ,每一分钟执行一次
    oracle_根据ID(字符型)建立分区表
    crawler_基础之_java.net.HttpURLConnection 访问网络资源
  • 原文地址:https://www.cnblogs.com/wust-ouyangli/p/4765619.html
Copyright © 2011-2022 走看看