zoukankan      html  css  js  c++  java
  • What Are You Talking About

    What Are You Talking About

    Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 102400/204800 K (Java/Others)
    Total Submission(s): 237 Accepted Submission(s): 117
     
    Problem Description
    Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
     
    Input
    The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab(' '), enter(' ') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
     
    Output
    In this problem, you have to output the translation of the history book.
     
    Sample Input
    START
    from fiwo
    hello difh
    mars riwosf
    earth fnnvk
    like fiiwj
    END
    START
    difh, i'm fiwo riwosf.
    i fiiwj fnnvk!
    END
     
    Sample Output
    hello, i'm from mars.
    i like earth!
    Hint
    Huge input, scanf is recommended.
     
    Author
    Ignatius.L
     
    /*
    STL乱搞
    */
    #include<bits/stdc++.h>
    using namespace std;
    string s1,s2;
    map<string,string>m;
    map<string,string>::iterator it;
    char op[3005];
    int main()
    {
        //freopen("C:\Users\acer\Desktop\in.txt","r",stdin);
        cin>>s1;
        //cout<<s1<<endl;
        while(cin>>s1)
        {
            if(s1=="END")
                break;
            cin>>s2;
            //cout<<s1<<" "<<s2<<endl;
            m.insert(pair<string,string>(s2,s1));
        }
        cin>>s1;
        //cout<<s1<<endl;
        getchar();
        while(gets(op))
        {
            s2=op;
            if(s2=="END")
                break;
            string str="";
            for(int i=0;i<s2.size();i++)
            {
                if( !((s2[i]>='a'&&s2[i]<='z')) )//不是字符
                {
                    it=m.find(str);
                    if(it==m.end())
                        cout<<str;
                    else
                        cout<<m[str];
                    //cout<<str<<endl;
                    str="";
                    cout<<s2[i];
                }
                else
                    str+=s2[i];
            }
            cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    redis 一主二从三哨兵
    java 调用axis2 webservice
    oracle 自增ID
    yum安装命令的使用方法
    SLES 10安装Oracle10gR2笔记
    信息系统集成资质等级评定条件(暂行)
    ionic imgBase64
    IOS 断点下载
    IOS JSON
    citrix更换vcenter后所需改动几张表
  • 原文地址:https://www.cnblogs.com/wuwangchuxin0924/p/6099079.html
Copyright © 2011-2022 走看看