zoukankan      html  css  js  c++  java
  • Be the Winner

    Be the Winner

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 63 Accepted Submission(s): 48
     
    Problem Description
    Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
    For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is
    the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
     
    Input
    You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
     
    Output
    If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
     
    Sample Input
    2
    2 2
    1
    3
     
    Sample Output
    No
    Yes
     
     
    Source
    ECJTU 2008 Autumn Contest
     
    Recommend
    lcy
     
    /*
    题意;n堆物品,谁拿最后一个谁输
    
    初步思路:裸的尼姆博弈
    */
    #include<bits/stdc++.h>
    using namespace std;
    int n;
    int res,a;
    int main(){
        // freopen("in.txt","r",stdin);
        int ca=0;
        while(scanf("%d",&n)!=EOF){
            res=0;
            int f=0;
            for(int i=0;i<n;i++){
                scanf("%d",&a);
                if(a>1) f=1;
                res^=a;
            }
            if(f) printf(res?"Yes
    ":"No
    ");
            else printf(n&1?"No
    ":"Yes
    ");
        }
        return 0;
    }
  • 相关阅读:
    递归和回溯_leetcode-floodfill
    递归和回溯_leetcode131
    递归和回溯_leetcode130
    递归和回溯_leetcode93-经典的回溯题
    递归和回溯_leetcode90
    递归和回溯_leetcode79
    递归和回溯_leetcode78-经典的子集
    知识树杂谈(1)
    Android 设备兼容性(1)
    微信小程序- 生成二维码
  • 原文地址:https://www.cnblogs.com/wuwangchuxin0924/p/6376475.html
Copyright © 2011-2022 走看看