zoukankan      html  css  js  c++  java
  • poj 1703 Find them, Catch them

    Find them, Catch them
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 46119   Accepted: 14193

    Description

    The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

    Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

    1. D [a] [b] 
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

    2. A [a] [b] 
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

    Input

    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

    Output

    For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

    Sample Input

    1
    5 5
    A 1 2
    D 1 2
    A 1 2
    D 2 4
    A 1 4
    

    Sample Output

    Not sure yet.
    In different gangs.
    In the same gang.
    

    Source

    /*
    * @Author: Lyucheng
    * @Date:   2017-07-20 20:33:57
    * @Last Modified by:   Lyucheng
    * @Last Modified time: 2017-07-20 22:12:50
    */
    /*
     题意:有两个帮派,两种操作:
        D x,y x和y是属于两个不同的帮派的
        A x,y 询问x和y的关系
    
     思路:二分染色问题,按照关系建边,如果x,y不在一个联通分量中的话就不能确定关系,如果在一个连通分量重
        那么直接判断与根节点的距离的奇偶
    */
    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <vector>
    #include <queue>
    #include <set>
    #include <map>
    #include <string>
    #include <math.h>
    #include <stdlib.h>
    #include <time.h>
    
    #define MAXN 100005
    
    using namespace std;
    
    int t;
    int n,m; 
    char str[2];
    int x,y;
    int bin[MAXN];
    int cnt[MAXN];//节点到根结点的距离的奇偶
    
    int findx(int x){
        int cur=x;
        int s=0;
        while(x!=bin[x]){
            if(cnt[x]==1){
                s++;
            }
            x=bin[x];
        }
        bin[cur]=x;
        cnt[cur]=s%2;
        return x;
    }
    
    void Union(int x,int y){
        int fx=findx(x);
        int fy=findx(y);
        if(fx!=fy){//不在一个集合内的才合并
            bin[fy]=fx;
            if(cnt[y]==0&&cnt[x]==0)
                cnt[fy]=1;
            else if(cnt[y]==0&&cnt[x]==1)
                cnt[fy]=0;
            else if(cnt[y]==1&&cnt[x]==0)
                cnt[fy]=0;
            else if(cnt[y]==1&&cnt[x]==1)
                cnt[fy]=1;
        }
    }
    
    void init(){
        for(int i=0;i<=n;i++){
            bin[i]=i;
        }
        memset(cnt,0,sizeof cnt);
    }
    
    int main(){ 
        // freopen("in.txt", "r", stdin);
        // freopen("out.txt", "w", stdout);
        scanf("%d",&t);
        while(t--){
            scanf("%d%d",&n,&m);
            init();
            for(int i=0;i<m;i++){
                scanf("%s%d%d",str,&x,&y);
                if(str[0]=='A'){//询问
                    int fx=findx(x);
                    int fy=findx(y);
                    if(fx!=fy){
                        puts("Not sure yet.");
                    }else{
                        if(cnt[x]==cnt[y]){
                            puts("In the same gang.");
                        }else{
                            puts("In different gangs.");
                        }
                    }
                }else{//关系
                    Union(x,y);
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    LIS(nlogn) POJ 3903 Stock Exchange
    LCS(滚动数组) POJ 1159 Palindrome
    LCS(打印全路径) POJ 2264 Advanced Fruits
    3-16 提取任务(第6章)
    3-15 《元编程》第6章 3-16 hook method
    3-13《元编程》第5章Class Definitions 3-14(5-4Singleton Classes,2小时)3-15(3小时✅)
    3-11 《Ruby元编程》第4章block块 3-12
    3-9《元编程》第3章Tuesday:methods
    3-8《Ruby元编程》第二章对象模型
    2-27 最短路径《啊哈算法》2-28完成四种算法
  • 原文地址:https://www.cnblogs.com/wuwangchuxin0924/p/7214804.html
Copyright © 2011-2022 走看看