zoukankan      html  css  js  c++  java
  • 【线段树】Atlantis

    Atlantis
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 23181   Accepted: 8644

    Description

    There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

    Input

    The input consists of several test cases. Each test case starts with a line containing a single integer n (1 <= n <= 100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0 <= x1 < x2 <= 100000;0 <= y1 < y2 <= 100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area. 
    The input file is terminated by a line containing a single 0. Don't process it.

    Output

    For each test case, your program should output one section. The first line of each section must be "Test case #k", where k is the number of the test case (starting with 1). The second one must be "Total explored area: a", where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point. 
    Output a blank line after each test case.

    Sample Input

    2
    10 10 20 20
    15 15 25 25.5
    0

    Sample Output

    Test case #1
    Total explored area: 180.00 

    Source

     
    题目大意:给出一些矩形,算他们的面积并
    试题分析:乍一看并不是用线段树,知道扫描线后就很好做了。
         扫描线是什么呢?
        扫描线可以从左到右或者从上到下(方向无所谓),就是从上开始扫,扫到一个矩形的开头那么这个矩形就可以进入我们的面积计算,扫到末尾就退出。
        这一过程我们就可以用线段树来维护,由于坐标可能有浮点数,所以就需要操作时离散化一下。
        这次没有写差分+离散化+线段树,差分要标记下传,直接储存也挺好做的
     
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<vector>
    #include<queue>
    #include<stack>
    #include<algorithm>
    using namespace std;
    
    inline int read(){
    	int x=0,f=1;char c=getchar();
    	for(;!isdigit(c);c=getchar()) if(c=='-') f=-1;
    	for(;isdigit(c);c=getchar()) x=x*10+c-'0';
    	return x*f;
    }
    const int MAXN=100001;
    const int INF=999999;
    int N,M;
    double a[100001],b[100001];
    int A[100001];
    struct data2{
    	double sum,len;
    	int ct;
    }tr[1000001];
    int tmp,tmp2;
    struct data{
    	double x,y1,y2;
    	bool end;
    }poi[1000001];
    int T;
    
    bool cmp(data a,data b){
    	return a.x<b.x;
    }
    void build(int l,int r,int rt){
    	tr[rt].ct=0;tr[rt].sum=0;
    	tr[rt].len=a[r]-a[l];
    	if(l+1>=r) return ;
    	int mid=(l+r)>>1; 
    	build(l,mid,rt*2);
    	build(mid,r,rt*2+1);
    	return ;
    }
    void Update(int rt,int l,int r){
    	if(tr[rt].ct) tr[rt].sum=tr[rt].len;
    	else if(r-l>1) tr[rt].sum=tr[rt*2].sum+tr[rt*2+1].sum;
    	else tr[rt].sum=0;
    	return ;
    }
    void add(int l,int r,int rt,int L,int R){
    	if(L==l&&R==r){
    		tr[rt].ct++;
    		Update(rt,l,r);
    		return ;
    	}
    	int mid=(l+r)>>1;
    	if(L>=mid) add(mid,r,rt*2+1,L,R);
    	else if(R<=mid) add(l,mid,rt*2,L,R);
    	else{
    		add(mid,r,rt*2+1,mid,R);
    		add(l,mid,rt*2,L,mid);
    	}
    	Update(rt,l,r);
    	return;
    }
    void del(int l,int r,int rt,int L,int R){
    	if(L==l&&R==r){
    		tr[rt].ct--;
    		Update(rt,l,r);
    		return ;
    	}
    	int mid=(l+r)>>1;
    	if(L>=mid) del(mid,r,rt*2+1,L,R);
    	else if(R<=mid) del(l,mid,rt*2,L,R);
    	else{
    		del(mid,r,rt*2+1,mid,R);
    		del(l,mid,rt*2,L,mid);
    	}
    	Update(rt,l,r);
    	return;
    }
    
    double ans;
    int main(){
        while(1){
        	N=read();
        	if(!N) break;
        	tmp2=tmp=0;double x1,x2,y1,y2;
    		for(int i=1;i<=N;i++){
    			cin>>x1>>y1>>x2>>y2;
    			poi[++tmp].x=x1;
    			poi[tmp].y1=y1;
    			poi[tmp].y2=y2;
    			poi[tmp].end=false;
    			poi[++tmp].x=x2;
    			poi[tmp].y1=y1;
    			poi[tmp].y2=y2;
    			poi[tmp].end=true;
    		}
    		for(int i=1;i<=tmp;i+=2){
    			a[tmp2]=b[tmp2]=poi[i].y1;tmp2++;
    		    a[tmp2]=b[tmp2]=poi[i].y2;tmp2++;
    		} 
    		sort(poi+1,poi+tmp+1,cmp);
    		sort(a,a+tmp2);
    		int tmp3=0,tmp4=0;
    		tmp3=unique(a,a+tmp2)-a;
    		ans=0;
    		build(0,tmp3-1,1);
    		double lasth;
    		for(int i=1;i<tmp;i++){
    			if(!poi[i].end) add(0,tmp3-1,1,lower_bound(a,a+tmp3,poi[i].y1)-a,lower_bound(a,a+tmp3,poi[i].y2)-a);
    			else del(0,tmp3-1,1,lower_bound(a,a+tmp3,poi[i].y1)-a,lower_bound(a,a+tmp3,poi[i].y2)-a);
    			ans+=(double)((poi[i+1].x-poi[i].x)*tr[1].sum);
    		}
    		printf("Test case #%d
    Total explored area: %.2f
    
    ",++T,ans);
    	} 
    }

      

  • 相关阅读:
    hibernate的核心配置
    hibernate的映射配置
    数据库的维护
    索引
    数据库规范化设计
    数据控制DCL
    触发器
    SQL存储过程简介
    Transact-SQL简介
    sysdatabaes表与sysobjects表
  • 原文地址:https://www.cnblogs.com/wxjor/p/7258163.html
Copyright © 2011-2022 走看看