zoukankan      html  css  js  c++  java
  • POJ2387-Till the cows come home【最短路】

    Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

    Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

    Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
    Input
    * Line 1: Two integers: T and N 

    * Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
    Output
    * Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100
    Sample Output
    90
    Hint
    INPUT DETAILS: 

    There are five landmarks. 

    OUTPUT DETAILS: 

    Bessie can get home by following trails 4, 3, 2, and 1.

    用的spfa算法  复杂度O(ME)

    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<cmath>
    #include<map>
    #include<cstring>
    #include<queue>
    #define inf 0x3f3f3f3f
    
    using namespace std;
    
    int t, n;
    int a[1005][1005], dis[1005];
    bool vis[1005];
    
    void spfa(int s)
    {
        for(int i = 1; i <= n; i++){
            dis[i] = inf;
            vis[i] = false;
        }
        dis[s] = 0;
        vis[s] = true;
        queue<int> que;
        que.push(s);
        int i, v;
        while(!que.empty()){
            v = que.front();que.pop();
            vis[v] = false;
            for(i = 1; i <= n; i++){
                if(a[v][i] > 0 && dis[i] > dis[v] + a[v][i]){
                    dis[i] = dis[v] + a[v][i];
                    if(vis[i] == 0){
                        que.push(i);
                        vis[i] = true;
                    }
                }
            }
        }
    
    }
    
    int main()
    {
        while(~scanf("%d%d",&t,&n)){
            memset(a, inf, sizeof(a));
            for(int i = 0; i < t; i++){
                int f, t, w;
                cin>>f>>t>>w;
                a[f][t] = min(a[f][t], w);
                a[t][f] = min(a[t][f], w);
            }
            spfa(n);
            cout<<dis[1]<<endl;
        }
    
        return 0;
    }

    要注意处理重边 注意先输入的是边的数目t





  • 相关阅读:
    学习进度三
    开课博客之个人介绍
    个人作业--数组
    学习进度二
    开学第一次测试
    实现点击不同的按钮加载不同的css
    Web存储
    HTML5(常用的表单控件)
    JS(获得当前时间并且用2015-01-01格式表示)
    JS(event事件)
  • 原文地址:https://www.cnblogs.com/wyboooo/p/9643431.html
Copyright © 2011-2022 走看看