zoukankan      html  css  js  c++  java
  • Doing Homework again(杭电1789)

    Doing Homework again

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 6833    Accepted Submission(s): 4070


    Problem Description
    Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
     

    Input
    The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
    Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
     

    Output
    For each test case, you should output the smallest total reduced score, one line per test case.
     

    Sample Input
    3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
     

    Sample Output
    0 3 5
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    int str[1010];  //用来标记该天是否占用,刚開始都未使用标记0,用过则标记1。 
    struct st
    {
        int time,fen;
    }data[1010]; 
    int cmp(st a,st b)  //科目按扣分从高到低排序。假设扣分同样。则科目期限短的考前。 
    {
        if(a.fen!=b.fen)
        return a.fen>b.fen;
        else
        return a.time<b.time;
    }
    int main()
    {
        int i,j,T,n;
        scanf("%d",&T);
        while(T--)
        {
            memset(str,0,sizeof(str));
            scanf("%d",&n);
            for(i=0;i<n;i++)
            {
                scanf("%d",&data[i].time);
            }
            for(i=0;i<n;i++)
            {
                scanf("%d",&data[i].fen);
            }
            sort(data,data+n,cmp);
            int sum=0;
            for(i=0;i<n;i++)   
            {
                j=data[i].time;
                while(j)    //将扣分多的科目优先放到期限的最后一天完毕。

    { if(!str[j]) //假设那天未被占用,占用那天。跳出while循环,再考虑扣分次多的那个科目。 { str[j]=1; break; } j--; // 假设那天已经被占用,考虑前一天是否被占用。 } if(j==0) sum+=data[i].fen; //假设在期限之内的全部天数均已经被占用。则不得不扣分。

    } printf("%d ",sum); } return 0; }




  • 相关阅读:
    GitBook基本使用
    Window 远程桌面漏洞风险,各个厂家的扫描修复方案(CVE-2019-0708)
    应急响应实战笔记(续)
    不同系统下,复制文件时新文件的日期区别
    Window应急响应(六):NesMiner挖矿病毒
    利用python输出000至999中间的数
    揭秘骗局:这是一张会变的图片
    如何查看github排行热度
    zabbix使用自动发现功能批量监控服务器端口的可用性
    使用python脚本批量设置nginx站点的rewrite规则
  • 原文地址:https://www.cnblogs.com/wzjhoutai/p/6763257.html
Copyright © 2011-2022 走看看