zoukankan      html  css  js  c++  java
  • HDU 1789 Doing Homework again

    Problem Description
    Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
     

    Input
    The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
    Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
     

    Output
    For each test case, you should output the smallest total reduced score, one line per test case.
     

    Sample Input
    3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
     

    Sample Output
    0 3 5
     

    Author
    lcy
     

    Source
     
    贪呀贪心。=。

    ==。=

    对完不成后的处罚排序(由大到小),依次遍历求解。

    这样能够保证最优,由于小于规定时间且处罚大的总是先遍历到。
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<limits.h>
    using namespace std;
    int t,n;
    struct node{
        int a,b;
    }s[1100];
    int hash[1100];
    int cmp(node l1,node l2)
    {
        if(l1.b!=l2.b)
            return l1.b>l2.b;
        return l1.a>l2.a;
    }
    int main()
    {
        int t,i,j;
        cin>>t;
        while(t--)
        {
            cin>>n;
            memset(hash,0,sizeof(hash));
            for(i=0;i<n;i++)
                cin>>s[i].a;
            for(i=0;i<n;i++)
                cin>>s[i].b;
            sort(s,s+n,cmp);
            int sum=0;
            for(i=0;i<n;i++)
            {
                for(j=s[i].a;j>0;j--)
                {
                    if(!hash[j])
                    {
                        hash[j]=1;
                        break;
                    }
                }
                if(j==0)
                  sum+=s[i].b;
            }
            cout<<sum<<endl;
        }
        return 0;
    }
    



  • 相关阅读:
    今天冷兔上线.
    tweenlite
    AS3中对String操作的replaceAll方法
    咫尺天涯的幸福
    ESPCMS系统模板结构图
    [转]AIR中调用exe或者bat可执行文件
    摘自《做人还是现实些》
    framespacing="10"和border="10"在frameSet中有什么区别?
    一个简单的div与span例子
    理解Javascript_05_原型继承原理 ,转载文章
  • 原文地址:https://www.cnblogs.com/wzjhoutai/p/6938370.html
Copyright © 2011-2022 走看看