zoukankan      html  css  js  c++  java
  • B

    My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

    My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

    What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

    Input

    One line with a positive integer: the number of test cases. Then for each test case:
    One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
    One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

    Output

    For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

    Sample Input

    3
    3 3
    4 3 3
    1 24
    5
    10 5
    1 4 2 3 4 5 6 5 4 2

    Sample Output

    25.1327
    3.1416
    50.2655

    分蛋糕,包括自己,每个人的面积要最大,每个人只能有一种蛋糕;
    用二分的方法就可以了

    #include<iostream>
    #include<stdio.h>
    #include<stdlib.h>
    #include<cmath>
    #include<string.h>
    #include<algorithm>
    #define sf scanf
    #define pf printf  
    #define mem(a,b) memset(a,b,sizeof(a))
    const double pi=acos(-1.0);
    typedef long long ll;
    typedef long double ld;
    const ll MOD=1e9+7;
    using namespace std;
    int n,m;
    
    
    int a[10005];
    bool judge(double mid)
    {
    	int ans=0;
    	for(int i=0;i<n;i++)
    	{
    		ans=ans+(int)(a[i]*a[i]*pi/mid);
    	}
    	if(ans>=m)
    	return true;
    	else
    	return false;
    }
    int main()
    {
    	int re;
    	cin>>re;
    	while(re--)
    	{
    		double sum=0;
    		mem(a,0);
    		sf("%d%d",&n,&m);
    		for(int i=0;i<n;i++)
    		{
    			sf("%d",&a[i]);
    			sum+=a[i]*a[i]*pi;
    		}
    		m++;
    		double left=0,right=sum/m;
    		double mid=(left+right)/2;
    		while(right-left>0.0001)
    		{
    			if(judge(mid))
    			left=mid;
    			else
    			right=mid;
    			mid=(left+right)/2;
    		}
    		pf("%.4lf
    ",mid);
    	}
    	return 0;
    }
    
  • 相关阅读:
    Codeforces Round #578 (Div. 2)
    Educational Codeforces Round 70
    Codeforces Round #576 (Div. 1)
    The 2019 ICPC China Nanchang National Invitational and International Silk-Road Programming Contest
    Educational Codeforces Round 69
    Codeforces Global Round 4
    Codeforces Round #574 (Div. 2)
    Educational Codeforces Round 68
    Codeforces Round #573 (Div. 1)
    The Preliminary Contest for ICPC China Nanchang National Invitational
  • 原文地址:https://www.cnblogs.com/wzl19981116/p/9350038.html
Copyright © 2011-2022 走看看