zoukankan      html  css  js  c++  java
  • G

    The Annual National Olympic of Information(NOI) will be held.The province of Shandong hold a Select(which we call SDOI for short) to choose some people to go to the NOI. n(n≤100) people comes to the Select and there is m(m≤50) people who can go to the NOI.

    According to the tradition and regulation.There were two rounds of the SDOI, they are so called "Round 1" and "Round 2", the full marks of each round is 300.

    All the n people take part in Round1 and Round2, now the original mark of every person is known. The rule of SDOI of ranking gets to the "standard mark". For each round there is a highest original mark,let's assume that is x.(it is promised that not all person in one round is 0,in another way,x>0). So for this round,everyone's final mark equals to his/her original mark∗(300/x).

    After we got everyone's final mark in both round.We calculate the Ultimate mark of everyone as 0.3∗round1′s final mark + 0.7∗round2′s final mark.It is so great that there were no two persons who have the same Ultimate mark.

    After we got everyone's Ultimate mark.We choose the persons as followed:

    To encourage girls to take part in the Olympic of Information.In each province,there has to be a girl in its teams.

    1. If there is no girls take part in SDOI,The boys with the rank of first m enter the team.
    2. If there is girls, then the girl who had the highest score(compared with other girls) enter the team,and other(boys and other girls) m-1 people with the highest mark enter the team.

    Just now all the examination had been finished.Please write a program, according to the input information of every people(Name, Sex ,The original mark of Round1 and Round2),Output the List of who can enter the team with their Ultimate mark decreasing.

    Input

    There is an integer T(T≤100) in the first line for the number of testcases and followed T testcases.

    For each testcase, there are two integers n and m in the first line(n≥m), standing for the number of people take part in SDOI and the allowance of the team.Followed with n lines,each line is an information of a person. Name(A string with length less than 20,only contain numbers and English letters),Sex(male or female),the Original mark of Round1 and Round2 (both equal to or less than 300) separated with a space.

    Output

    For each testcase, output "The member list of Shandong team is as follows:" without Quotation marks.

    Followed m lines,every line is the name of the team with their Ultimate mark decreasing.

    Sample Input

    2
    10 8
    dxy male 230 225
    davidwang male 218 235
    evensgn male 150 175
    tpkuangmo female 34 21
    guncuye male 5 15
    faebdc male 245 250
    lavender female 220 216
    qmqmqm male 250 245
    davidlee male 240 160
    dxymeizi female 205 190
    2 1
    dxy male 300 300
    dxymeizi female 0 0

    Sample Output

    The member list of Shandong team is as follows:
    faebdc
    qmqmqm
    davidwang
    dxy
    lavender
    dxymeizi
    davidlee
    evensgn
    The member list of Shandong team is as follows:
    dxymeizi

    Hint

    For the first testcase: the highest mark of Round1 if 250,so every one's mark times(300/250)=1.2, it's same to Round2.
    The Final of The Ultimate score is as followed
    faebdc 298.20
    qmqmqm 295.80
    davidwang 275.88
    dxy 271.80
    lavender 260.64
    dxymeizi 233.40
    davidlee 220.80
    evensgn 201.00
    tpkuangmo 29.88
    guncuye 14.40

    For the second testcase,There is a girl and the girl with the highest mark dxymeizi enter the team, dxy who with the highest mark,poorly,can not enter the team.

    就是一个简单的排序,难得这题直接过了

    #include<iostream>
    #include<stdio.h>
    #include<stdlib.h>
    #include <iomanip>
    #include<cmath>
    #include<string.h>
    #include<algorithm>
    #define sf scanf
    #define pf printf
    #define pb push_back
    #define mm(x,b) memset((x),(b),sizeof(x))
    #include<vector>
    #include<map>
    //#define for(i,a,b) for(int i=a;i<b;i++)
    typedef long long ll;
    typedef long double ld;
    const ll mod=1e9+7;
    using namespace std;
    const double pi=acos(-1.0);
    int max(int a,int b){return a>b?a:b;}
    struct qq
    {
    	string name;
    	string se;
    	int x1,x2;
    	double score;
    }a[105];
    bool cmp(qq a,qq b)
    {
    	return a.score >b.score;
    }
    int main()
    {
    	int re;
    	cin>>re;
    	while(re--)
    	{
    		int n,m;
    		cin>>n>>m;int temp=0;
    		int x,y;
    		int Max1=0,Max2=0;
    		for(int i=0;i<n;i++)
    		{
    			cin>>a[i].name>>a[i].se>>a[i].x1>>a[i].x2;
    			if(a[i].se=="female") temp=1;
    			Max1=max(Max1,a[i].x1);
    			Max2=max(Max2,a[i].x2);
    		}
    		for(int i=0;i<n;i++)
    			a[i].score=0.3*a[i].x1*300/Max1+0.7*a[i].x2 *300/Max2;
    		sort(a,a+n,cmp);
    		pf("The member list of Shandong team is as follows:
    ");
    		int ans=0,i;
    		if(temp)
    		{
    			for(i=0;i<m-1;i++)
    			{
    				cout<<a[i].name <<endl;
    				if(a[i].se=="female")
    				ans=1;
    			}
    			if(ans==0)
    			for(;i<n;i++)
    			{
    				if(a[i].se =="female")
    				{
    					cout<<a[i].name<<endl;;
    					break;
    				}
    			}
    			else
    			cout<<a[i].name<<endl ;
    		}else
    		{
    			for(i=0;i<m;i++)
    				cout<<a[i].name <<endl;
    		}
    	}
    	return 0;
    }
    
  • 相关阅读:
    LeetCode题解之Leaf-Similar Trees
    LeetCode题解之 Increasing Order Search Tree
    建立git仓库的步骤
    Jquery-1(基础)
    JavaScript-12(脚本化CSS)
    JavaScript-11(DOM文档对象模型)
    JavaScript-10(JavaScript事件)
    JavaScript-实现下拉菜单
    JavaScript-9(BOM浏览器对象模型)
    JavaScript-字符与编码转换
  • 原文地址:https://www.cnblogs.com/wzl19981116/p/9379944.html
Copyright © 2011-2022 走看看