zoukankan      html  css  js  c++  java
  • F

    The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the ls function.

    Your program will eventually read input from a pipe (although for now your program will read from the input file). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to right.

    Input

    The input file will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer (1 N 100). There will then be N lines each containing one left-justified filename and the entire line’s contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a to z, A to Z, and 0 to 9) and from the following set {._-} (not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty.

    Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input file.

    Output

    For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to R will be listed down column 1; filenames R + 1 to 2R listed down column 2; etc.

    Sample Input

    10
    tiny
    2short4me
    very_long_file_name
    shorter
    size-1
    size2
    size3
    much_longer_name
    12345678.123
    mid_size_name
    12
    Weaser
    Alfalfa
    Stimey
    Buckwheat
    Porky
    Joe
    Darla
    Cotton
    Butch
    Froggy
    Mrs_Crabapple
    P.D.
    19
    Mr._French
    Jody
    Buffy
    Sissy
    Keith
    Danny
    Lori
    Chris
    Shirley
    Marsha
    Jan
    Cindy
    Carol
    Mike
    Greg
    Peter
    Bobby
    Alice
    Ruben
    Sample Output

    12345678.123 size-1
    2short4me size2
    mid_size_name size3
    much_longer_name tiny
    shorter very_long_file_name

    Alfalfa Cotton Joe Porky
    Buckwheat Darla Mrs_Crabapple Stimey
    Butch Froggy P.D. Weaser

    Alice Chris Jan Marsha Ruben
    Bobby Cindy Jody Mike Shirley
    Buffy Danny Keith Mr._French Sissy
    Carol Greg Lori Peter

    排好后从左开始一列一列向下打印,前面的要最大长度加2,最后一列是最大长度,总长度不大于60

    题目看错,改了一万年

    #include<iostream>
    #include<stdio.h>
    #include<stdlib.h>
    #include <iomanip>
    #include<cmath>
    #include<string.h>
    #include<algorithm>
    #define sf scanf
    #define pf printf
    #define pb push_back
    #define mm(x,b) memset((x),(b),sizeof(x))
    #include<vector>
    #include<map>
    //#define for(i,a,b) for(int i=a;i<b;i++)
    typedef long long ll;
    typedef long double ld;
    const ll mod=1e9+7;
    using namespace std;
    const double pi=acos(-1.0);
    int max(int a,int b){return a>b?a:b;}
    
    void first()
    {
    	for(int i=0;i<60;i++)
    	pf("-");
    	pf("
    ");
    }
    int main() 
    {
    //	f	reopen("output1.txt", "r", stdin);
    	int n;
    	cout.setf(std::ios::left);
    	while(~sf("%d",&n))
    	{
    	//	getchar();
    		
    		string a[105];
    		int Max=0;
    		for(int i=0;i<n;i++)
    		{
    			cin>>a[i];
    			Max=max(Max,a[i].size());
    		}
    		first();
    		int m=(60-Max)/(Max+2)+1;//m是确定一行多少个 
    		int sum=n/m;//sum是多少行
    		int ans=n%m;//ans是最后一行多少列 
    		int i=1,time=0,temp=0;
    		if(ans) sum++;
    		sort(a,a+n);
    		for(int i=0;i<sum;i++)
    		{
    			for(int j=0;j<m;j++)
    			{
    				if(j*sum+i+1>n) break;
    				if(j==m-1)
    				cout<<setfill(' ')<<setw(Max)<<a[j*sum+i];
    				else
    				cout<<setfill(' ')<<setw(Max+2)<<a[j*sum+i];
    			}
    			cout<<endl;
    		}
    		
    	}
    	return 0;
    }
    
  • 相关阅读:
    spring项目(springmvc)(多模块/单模块)maven打包引入第三方jar方式,使用scope:system配置systemPath编译,不用添加到本地仓库!
    Mysql 执行效率 性能综合贴
    前端Js框架 UI框架汇总 特性 适用范围 选择
    通用 正则表达式 C# (.NET)Regex 总结
    VSCode Node cannot launch program setting the 'outFiles' attribute might help
    CSS常见问题,定位技巧总结
    java 欢迎页 主页 设置为servlet的方法
    MSSQL Server 及 MSSQL Express版本 自动备份
    SQL Server 2008 R2 安装 下载
    mysql 日期计算集合
  • 原文地址:https://www.cnblogs.com/wzl19981116/p/9380805.html
Copyright © 2011-2022 走看看