zoukankan      html  css  js  c++  java
  • A

    Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
    To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
    The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
    You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

    Input

    The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

    Output

    Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
    If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

    Sample Input

    4 11
    8.02
    7.43
    4.57
    5.39

    Sample Output

    2.00

    二分我肯定是个傻子要注意给的单位是木..;

    #include<iostream>
    #include<stdio.h>
    #include<stdlib.h>
    #include <iomanip>
    #include<cmath>
    #include<string.h>
    #include<algorithm>
    #define sf scanf
    #define pf printf
    #define pb push_back
    #define mm(x,b) memset((x),(b),sizeof(x))
    #include<vector>
    #include<map>
    #define for(i,a,b) for(int i=a;i<b;i++)
    typedef long long ll;
    typedef long double ld;
    const ll mod=1e9+7;
    using namespace std;
    const double pi=acos(-1.0);
    double b[10005];int n,m,a[10005];
    bool judge(int mid)
    {
    	int sum=0;
    	for(i,0,n)
    	{
    		sum+=a[i]/mid;
    	}
    	return sum>=m;
    }
    int main()
    {
    	int sum=0;
    	int Max=0;
    	cin>>n>>m;
    	for(i,0,n)
    	{
    		cin>>b[i];
    		a[i]=b[i]*100;
    		sum+=a[i]/100;
    		Max=max(Max,a[i]);
    	}
    /*	if(sum<m)
    	{
    		cout<<"0.00";
    		return 0;
    	}*/
    	int left=0,right=Max+1,mid;
    	while(right-left>1)
    	{
    		mid=(left+right)/2;
    		if(judge(mid))
    		left=mid;
    		else
    		right=mid;
    	}
    	if(judge(right))pf("%.2f",(double)right/100.00);
    	else
    	pf("%.2f",(double)left/100.00);
    	return 0;
    }
    
  • 相关阅读:
    Mac搭建PHP多站点虚拟主机环境
    IE ajax缓存问题
    CSS hack总结
    div高度自适应
    asp.net EasyUI DataGrid 实现增删改查
    如何从 Windows Phone 8 模拟器连接到本地 Web 服务
    创建DomainService,添加终结点
    sqlserver 查询数量查看,并快速建立索引。
    在VS2013中强制IIS Express应用程序池使用经典模式
    理解HTTP幂等性
  • 原文地址:https://www.cnblogs.com/wzl19981116/p/9381222.html
Copyright © 2011-2022 走看看