zoukankan      html  css  js  c++  java
  • F

    来源poj 2398

    Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
    Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:

    We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

    Input

    The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

    A line consisting of a single 0 terminates the input.

    Output

    For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

    Sample Input

    4 10 0 10 100 0
    20 20
    80 80
    60 60
    40 40
    5 10
    15 10
    95 10
    25 10
    65 10
    75 10
    35 10
    45 10
    55 10
    85 10
    5 6 0 10 60 0
    4 3
    15 30
    3 1
    6 8
    10 10
    2 1
    2 8
    1 5
    5 5
    40 10
    7 9
    0

    Sample Output

    Box
    2: 5
    Box
    1: 4
    2: 1

    和前一题一样,只是改了一下输出的东西而已

    #include<iostream>
    #include<stdio.h>
    #include<stdlib.h>
    #include <iomanip>
    #include<cmath>
    #include<float.h> 
    #include<string.h>
    #include<algorithm>
    #define sf scanf
    #define pf printf
    #define mm(x,b) memset((x),(b),sizeof(x))
    #include<vector>
    #include<queue>
    #include<stack>
    #include<map>
    #define rep(i,a,n) for (int i=a;i<n;i++)
    #define per(i,a,n) for (int i=a;i>=n;i--)
    typedef long long ll;
    typedef long double ld;
    typedef double db;
    const ll mod=1e9+100;
    const db e=exp(1);
    const db eps=1e-8;
    using namespace std;
    const double pi=acos(-1.0);
    const int inf=0xfffffff;
    struct point
    {
    	int x,y;
    	point(int a=0,int b=0)
    	{
    		x=a;y=b;
    	}
    }t;
    struct xl
    {
    	point p1,p2;//p1是下面的点 
    	int sum;
    	xl(int x=0,int y=0,int a=0,int b=0)
    	{
    		p1=point(x,y);
    		p2=point(a,b);sum=0;
    	}
    }a[5005];
    bool cmp(xl a,xl b)
    {
    	return a.p1.x<b.p1.x;
    }
    bool cmp1(xl a,xl b)
    {
    	return a.sum<b.sum;
    }
    int direction(point p1,point p2,point p3)//p1是向量起点,p2是终点,p3是判断点,》0则在左边<0在右侧 
    {
    	return (p1.x-p3.x)*(p2.y-p3.y)-(p1.y-p3.y)*(p2.x-p3.x);
    }
    int main()
    {
    	int n,m,X1,X2,Y1,Y2,x,y;
    	int jud=1;
    	while(1)
    	{
    		cin>>n;
    		if(!n) 
    		return 0;
    		cin>>m>>X1>>Y1>>X2>>Y2;
    		rep(i,0,n)
    		{
    			cin>>x>>y;
    			a[i]=xl(y,Y2,x,Y1);
    		}
    		a[n]=xl(); 
    		sort(a,a+n,cmp);
    		while(m--)
    		{
    			int temp=0;
    			cin>>t.x>>t.y;
    			rep(i,0,n)
    			{
    				if(direction(a[i].p1,a[i].p2,t)>0)
    				{
    					a[i].sum++;temp=1;
    					break;
    				}
    			}
    			if(!temp)
    			a[n].sum++;
    		}
    		sort(a,a+n+1,cmp1);
    		int last=-1;
    		pf("Box
    ");
    		rep(i,0,n+1)
    		{
    			int num=1;
    			last=a[i].sum;
    			int j; 
    			for(j=1;i+j<=n+1;j++)
    			{
    				if(a[i+j].sum!=last)
    				{
    					break;
    				}
    					num++;
    				}
    			i=i+j-1;
    			if(last==0) continue;
    			pf("%d: %d
    ",last,num);
    		}
    	}
    } 
    
  • 相关阅读:
    shell习题第12题:批量创建用户
    shell习题第11题:输入数字执行命令
    二、python数据类型、字符编码、文件处理
    C语言之控制语言:分支和跳转
    c语言之控制语句:循环
    C语言之运算符、表达式和语句
    Python集合及其运算
    Python文本处理
    Python迭代器与格式化
    Python装饰器
  • 原文地址:https://www.cnblogs.com/wzl19981116/p/9426608.html
Copyright © 2011-2022 走看看