zoukankan      html  css  js  c++  java
  • hdu 4925 Apple Tree--2014 Multi-University Training Contest 6

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4925


    Apple Tree

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
    Total Submission(s): 188    Accepted Submission(s): 129


    Problem Description
    I’ve bought an orchard and decide to plant some apple trees on it. The orchard seems like an N * M two-dimensional map. In each grid, I can either plant an apple tree to get one apple or fertilize the soil to speed up its neighbors’ production. When a grid is fertilized, the grid itself doesn’t produce apples but the number of apples of its four neighbor trees will double (if it exists). For example, an apple tree locates on (x, y), and (x - 1, y), (x, y - 1) are fertilized while (x + 1, y), (x, y + 1) are not, then I can get four apples from (x, y). Now, I am wondering how many apples I can get at most in the whole orchard?
     

    Input
    The input contains multiple test cases. The number of test cases T (T<=100) occurs in the first line of input.
    For each test case, two integers N, M (1<=N, M<=100) are given in a line, which denote the size of the map.
     

    Output
    For each test case, you should output the maximum number of apples I can obtain.
     

    Sample Input
    2 2 2 3 3
     

    Sample Output
    8 32
     

    Source
     

    Recommend
    hujie   |   We have carefully selected several similar problems for you:  4929 4928 4926 4924 4923 
     

    Statistic | Submit | Discuss | Note


    签道题,没啥好说的,黑白染色的方法是最优的,特判1*1的情况


    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<string>
    #include<cmath>
    #include<string>
    #include<vector>
    #include<algorithm>
    #include<queue>
    #include<stack>
    #include<set>
    #include<map>
    using namespace std;
    #define CLR(A) memset(A,0,sizeof(A))
    int A[110][110];
    int main(){
        int T,m,n;
        cin>>T;
        while(T--){
            cin>>n>>m;
            if(n==1 && m==1){
                cout<<1<<endl;
                continue;
            }
            for(int i=1;i<=n;i++)
                for(int j=1;j<=m;j++)
                    A[i][j]=1;
            for(int i=1;i<=n;i++)
                for(int j=1;j<=m;j++){
                    if(A[i][j]==1){
                        A[i-1][j]<<=1;
                        A[i+1][j]<<=1;
                        A[i][j-1]<<=1;
                        A[i][j+1]<<=1;
                    }
                }
            long long sum=0;
            for(int i=1;i<=n;i++)
                for(int j=1;j<=m;j++){
                    if(A[i][j]!=1){
                        sum+=A[i][j];
                    }
                }
            cout<<sum<<endl;
        }
        return 0;
    }
    






  • 相关阅读:
    Silverlight:拖动滚动条控制媒体播放
    黑马程序员第一阶段3.面向对象第5天
    黑马程序员第一阶段2.java编程基础第4天
    黑马程序员第一阶段2.java编程基础第2天
    黑马程序员第一阶段2.java编程基础第3天
    黑马程序员第一阶段3.面向对象第6天
    黑马程序员第一阶段3.面向对象第8天
    黑马程序员第一阶段3.面向对象第7天
    黑马程序员第一阶段1.Java开发前奏第1天
    hdu 1133
  • 原文地址:https://www.cnblogs.com/wzzkaifa/p/6901870.html
Copyright © 2011-2022 走看看