zoukankan      html  css  js  c++  java
  • HDU 1159 Common Subsequence (动规+最长公共子序列)

    Common Subsequence

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 22698    Accepted Submission(s): 9967



    Problem Description
    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
    The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
     

    Sample Input
    abcfbc abfcab programming contest abcd mnp
     

    Sample Output
    4 2 0
     

    Source
     

    Recommend
    Ignatius   |   We have carefully selected several similar problems for you:  1176 1058 1421 1160 1978
    题目大意:求最长公共子序列。
    在一些细节上有借鉴的地方,其它没什么了。


    代码:

    #include <iostream>
    #include <string.h>
    using namespace std;
    #define M 1000
    #define max(a,b) (a>b?a:b)
    char ma1[M],ma2[M];
    int dp[M][M];
    int main(int i,int j,int k)
    { 
        int l1,l2;
      while(scanf("%s%s",ma1+1,ma2+1)!=EOF)         //这是个有意思的地方,由于在后面要用动规从1->l1,所以字符串从1開始。
      {   
          memset(dp,0,sizeof(dp));
          l1=strlen(ma1+1);                        //strlen是測字符串长度,没办法,还要+1.
          l2=strlen(ma2+1);
    
          for(i=1;i<=l1;i++)                       //这里就是模板。不说明了。

    for(j=1;j<=l2;j++) { if(ma1[i]==ma2[j]) dp[i][j]=dp[i-1][j-1]+1; else dp[i][j]=max(dp[i][j-1],dp[i-1][j]); } printf("%d ",dp[l1][l2]); } return 0; }


     
  • 相关阅读:
    算符优先分析
    自下而上语法分析
    递归下降语法分析
    LL(1)文法的判断,递归下降分析程序
    消除左递归
    4.K均值算法--应用
    2.机器学习相关数学基础
    K均值算法
    机器学习概述
    算符优先分析
  • 原文地址:https://www.cnblogs.com/wzzkaifa/p/6943463.html
Copyright © 2011-2022 走看看