zoukankan      html  css  js  c++  java
  • 数组练习题A财务管理

    • 第一次看全英文的题,还是有点不舒服的感觉,还是用了翻译器
      Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

      Input
      The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

      Output
      The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output

      Sample Input
      100.00
      489.12
      12454.12
      1234.10
      823.05
      109.20
      5.27
      1542.25
      839.18
      83.99
      1295.01
      1.75
      Sample Output
      $1581.42

    代码样例:

    #include<stdio.h>
    
    #define N 12
    
    int main()
    
    {
    
    double m=0,l;
    
    double s[N];
    
    int i;
    
    for(i=0;i<N;i++)
    
    {scanf("%lf
    ",&s[i]);        
    
    m=m+s[i];}
    
    l=m/N;
    
    printf("$");
    
    printf("%.2lf",l);
    
    return 0;
    
    } 
    
    • 定义一个可以存放十二个数值的数组,循环累加,计算平均
  • 相关阅读:
    Linux端口被占用解决
    Django Uwsgi Nginx 部署
    django 取出数据库的时间与当前时间相加减
    C++分支语句
    简单的C++程序
    菜鸟简短的自述以及C++介绍
    springboot maven项目打包SAPJCO3.JAR
    SAPJCO3升级3.1后报错java.lang.UnsatisfiedLinkError: sapjco3.dll解决
    sqlserver 修改数据库用户登录名
    yml字符串值写法,单双引号区别,换行用法
  • 原文地址:https://www.cnblogs.com/xiao--liang/p/10243726.html
Copyright © 2011-2022 走看看