zoukankan      html  css  js  c++  java
  • [POJ3295]Tautology

    [POJ3295]Tautology

    试题描述

    WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

    • p, q, r, s, and t are WFFs
    • if w is a WFF, Nw is a WFF
    • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.

    The meaning of a WFF is defined as follows:

    • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
    • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
    Definitions of K, A, N, C, and E
         w  x   Kwx   Awx    Nw   Cwx   Ewx
      1  1   1   1    0   1   1
      1  0   0   1    0   0   0
      0  1   0   1    1   1   0
      0  0   0   0    1   1   1

    tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

    You must determine whether or not a WFF is a tautology.

    输入

    Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

    输出

    For each test case, output a line containing tautology or not as appropriate.

    输入示例

    ApNp
    ApNq
    0

    输出示例

    tautology
    not

    数据规模及约定

    见“输入

    题解

    枚举 p, q, r, s, t 的值,然后带进去递归求出这个串的值,如果都为真那么就是“tautology”,否则是“not”。

    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    #include <cmath>
    #include <stack>
    #include <vector>
    #include <queue>
    #include <cstring>
    #include <string>
    #include <map>
    #include <set>
    using namespace std;
    
    #define maxn 110
    #define maxal 300
    char S[maxn];
    int ord[maxal];
    bool val[10];
    
    struct Info {
    	int p, v;
    	Info() {}
    	Info(int _, int __): p(_), v(__) {}
    } ;
    Info check(int l) {
    	if(islower(S[l])) return Info(l + 1, val[ord[S[l]]]);
    	if(S[l] == 'N') {
    		Info t;
    		t = check(l + 1);
    		return Info(t.p, t.v ^ 1);
    	}
    	if(S[l] == 'K') {
    		Info t, t2;
    		t = check(l + 1);
    		t2 = check(t.p);
    		return Info(t2.p, t.v & t2.v);
    	}
    	if(S[l] == 'A') {
    		Info t, t2;
    		t = check(l + 1);
    		t2 = check(t.p);
    		return Info(t2.p, t.v | t2.v);
    	}
    	if(S[l] == 'C') {
    		Info t, t2;
    		t = check(l + 1);
    		t2 = check(t.p);
    		return Info(t2.p, (t.v && !t2.v) ? 0 : 1);
    	}
    	if(S[l] == 'E') {
    		Info t, t2;
    		t = check(l + 1);
    		t2 = check(t.p);
    		return Info(t2.p, t.v == t2.v);
    	}
    	return Info(0, 0);
    }
    
    int main() {
    	ord['p'] = 0;
    	ord['q'] = 1;
    	ord['r'] = 2;
    	ord['s'] = 3;
    	ord['t'] = 4;
    	while(scanf("%s", S + 1) == 1) {
    		int all = (1 << 5) - 1, n = strlen(S + 1);
    		if(n == 1 && S[1] == '0') break;
    		bool ok = 1;
    		for(int i = 0; i <= all; i++) {
    			for(int j = 0; j < 5; j++)
    				val[j] = (i >> j & 1);
    			if(!check(1).v){ ok = 0; break; }
    		}
    		puts(ok ? "tautology" : "not");
    	}
    	
    	return 0;
    }
    
  • 相关阅读:
    一个高级的makefile文件
    poj3616题(动态规划),看了别人的提示,自己又写了一遍
    浅谈C++ IO标准库(1)
    https证书安装踩坑
    一个简单通知服务的开发和搭建
    WCF学习笔记
    线程(Thread)、线程池(ThreadPool)技术
    BackgroundWorker与线程使用
    使用ITextSharp生成PDF文件心得
    值类型与引用类型
  • 原文地址:https://www.cnblogs.com/xiao-ju-ruo-xjr/p/6103877.html
Copyright © 2011-2022 走看看