zoukankan      html  css  js  c++  java
  • poj 1001

    Exponentiation
    Time Limit: 500MS   Memory Limit: 10000K
    Total Submissions: 118340   Accepted: 28851

    Description

    Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

    This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

    Input

    The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

    Output

    The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

    Sample Input

    95.123 12
    0.4321 20
    5.1234 15
    6.7592  9
    98.999 10
    1.0100 12
    

    Sample Output

    548815620517731830194541.899025343415715973535967221869852721
    .00000005148554641076956121994511276767154838481760200726351203835429763013462401
    43992025569.928573701266488041146654993318703707511666295476720493953024
    29448126.764121021618164430206909037173276672
    90429072743629540498.107596019456651774561044010001
    1.126825030131969720661201
    import java.io.*;
    import java.math.*;
    import java.util.*;
    
    
    public class Main {
    
        public static void main(String[] args) {
            Scanner cin = new Scanner(new BufferedInputStream(System.in));
            BigDecimal a;
            String s ;
            int b,star,end;
            while(cin.hasNext())
            {
                a = cin.nextBigDecimal();
                b = cin.nextInt();
                a = a.pow(b);
                s = new String(a.toPlainString());
                star=0;end = s.length()-1;
                while(s.charAt(star)=='0') star++;
                while(s.charAt(end)=='0') end--;
                if(s.charAt(end) == '.') end --; 
                for(int i=star;i<=end;i++)
                    System.out.print(s.charAt(i));
                System.out.println();
            }
        }
        
    }
  • 相关阅读:
    50.2 Django 连接MySQL,django orm 数据库(models)操作
    50.1 Django 静态资源配置 static && form表单和 request对象
    JS备忘
    Python 单元测试 生产HTML测试报告
    python 单元测试 执行测试
    pycharm 安装插件
    Python 单元测试 实战演练
    Python 单元测试
    Pycharm 使用备忘
    Python 异常
  • 原文地址:https://www.cnblogs.com/xiaofanke/p/3116045.html
Copyright © 2011-2022 走看看