zoukankan      html  css  js  c++  java
  • String Matching

    String Matching
    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
    Total Submission(s) : 50   Accepted Submission(s) : 15
    Problem Description
    It's easy to tell if two words are identical - just check the letters. But how do you tell if two words are almost identical? And how close is "almost"?

    There are lots of techniques for approximate word matching. One is to determine the best substring match, which is the number of common letters when the words are compared letter-byletter.

    The key to this approach is that the words can overlap in any way. For example, consider the words CAPILLARY and MARSUPIAL. One way to compare them is to overlay them:

    CAPILLARY
    MARSUPIAL

    There is only one common letter (A). Better is the following overlay:

    CAPILLARY
         MARSUPIAL
    with two common letters (A and R), but the best is:

       CAPILLARY
    MARSUPIAL
    Which has three common letters (P, I and L).

    The approximation measure appx(word1, word2) for two words is given by:

    common letters * 2
    -----------------------------
    length(word1) + length(word2)

    Thus, for this example, appx(CAPILLARY, MARSUPIAL) = 6 / (9 + 9) = 1/3. Obviously, for any word W appx(W, W) = 1, which is a nice property, while words with no common letters have an appx value of 0.
     

    Input
    The input for your program will be a series of words, two per line, until the end-of-file flag of -1.
    Using the above technique, you are to calculate appx() for the pair of words on the line and print the result.
    The words will all be uppercase.
     

    Output
    Print the value for appx() for each pair as a reduced fraction,Fractions reducing to zero or one should have no denominator.
     

    Sample Input
    CAR CART
    TURKEY CHICKEN
    MONEY POVERTY
    ROUGH PESKY
    A A
    -1

    Sample Output
    appx(CAR,CART) = 6/7
    appx(TURKEY,CHICKEN) = 4/13
    appx(MONEY,POVERTY) = 1/3
    appx(ROUGH,PESKY) = 0
    appx(A,A) = 1


    #include <stdio.h>
    #include <string.h>
    #define MAX 1000

    char a[MAX];
    char b[MAX];

    int xt(int i,int j,int l1,int l2)
    {
     int k=0;
     for(;i<l1;i++)
     {
      if(a[i]==b[j])
      k++;
            j++;
      if(j>=l2) break;
     }
     return k;
    }
    int gcd(int a,int b)
    {
     int t=1;
     while(t)
     {
      t=b%a;
      b=a;
      a=t;
     }
     return b; 
    }
    int main()
    {
     while(scanf("%s",a)&&(strcmp(a,"-1")!=0))
     {
      int i,j,k,t,l1,l2,num;
      scanf("%s",b);
      l1=strlen(a);
      l2=strlen(b);
      num=t=k=0;
      for(i=0;i<l1;i++)
      {
       for(j=0;j<l2;j++)
       {
        if(a[i]==b[j])
        {
         t=xt(i,j,l1,l2);
         if(t>num)
         {num=t;t=0;}
         break;
        }
       }
      }
      if(num==0)
      printf("appx(%s,%s) = 0 ",a,b);
      else if(num*2==l1+l2)
      printf("appx(%s,%s) = 1 ",a,b);
      else
      {
      k=gcd(num*2,l1+l2);
      printf("appx(%s,%s) = %d/%d ",a,b,num*2/k,(l1+l2)/k);
      }
     }
     return 0;
    }

  • 相关阅读:
    Code Generation and T4 Text Templates
    Pros and Cons of T4 in Visual Studio 2008
    PSPInstance Object | Web Python
    Mod_Python中文文档
    [Medusa-dev] psp_handler
    Difference Between Mod_Python & Mod_Wsgi | eHow
    Mod_python: The Long Story
    HOWTO Use Python in the web — Python v3.0.1 documentation
    Js~对数组进行分组户数
    大叔也说并行和串行`性能提升N倍(N由操作系统位数和cpu核数决定)
  • 原文地址:https://www.cnblogs.com/xiaziteng/p/3253989.html
Copyright © 2011-2022 走看看