zoukankan      html  css  js  c++  java
  • Let the Balloon Rise--1004

    Let the Balloon Rise
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 57692    Accepted Submission(s): 21088


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.

    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.

    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

    Sample Input
    5
    green
    red
    blue
    red
    red
    3
    pink
    orange
    pink
    0
     

    Sample Output
    red
    pink
     

    #include <stdio.h>
    #include <string.h>
    int main()
    {
        int n,a[1000],max,i,j,t;
        char color[1000][16];
        while(scanf("%d",&n)!=EOF)
        {
         if(n)
         {
          a[0]=0;
          scanf("%s",color[0]);
          for(i=1;i<n;i++)
          {   a[i]=0;
           scanf("%s",color[i]);
          for(j=0;j<i;j++)
          if(strcmp(color[i],color[j])==0)
          a[i]+=1;}
                max=a[0];
                t=0;
         for(i=1;i<n;i++)
         {if(max<a[i])
         {max=a[i];t=i;}
         }
            printf("%s ",color[t]);
         }
        }
        return 0;
    }

  • 相关阅读:
    百度面试题
    京东2014年招聘会成都站笔试经历
    把一个字符串的大写字母放到字符串的后面,各个字符的相对位置不变,不能申请额外的空间
    POJ 2234 Matches Game
    POJ 3903 Stock Exchange
    POJ 2853 Sequence Sum Possibilities
    POJ 3519 Minimal Backgammon
    POJ 2096 Collecting Bugs
    POJ 3071 Football
    HDU 1175 连连看
  • 原文地址:https://www.cnblogs.com/xiaziteng/p/HDOJ--1004.html
Copyright © 2011-2022 走看看