zoukankan      html  css  js  c++  java
  • hdu2010(dfs+剪枝)

    Tempter of the Bone

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 131619    Accepted Submission(s): 35432


    Problem Description
    The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

    The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
     
    Input
    The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

    'X': a block of wall, which the doggie cannot enter;
    'S': the start point of the doggie;
    'D': the Door; or
    '.': an empty block.

    The input is terminated with three 0's. This test case is not to be processed.
     
    Output
    For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
     
    Sample Input
    4 4 5
    S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
     
    Sample Output
    NO
    YES
     
    题意是恰好走k步从S点到达D点,所以我们需要剪枝。
    1:s点的坐标减去d点的坐标要恰好等于k..即:abs(ax-bx)+abs(ay-by)==k;
    2:判断奇偶:假设
    1 0 1 0 1
    0 1 0 1 0
    1 0 1 0 1
    0 1 0 1 0
    我们发现从0走一步一定走到1,从1走一步一定走到0。
    也就是说,如果当前的狗所在的坐标与D的坐标奇偶性不一样,那么狗需要走奇数步。
    同理,如果狗所在坐标与D的坐标奇偶性一样,那么狗需要走偶数步数。
     
    也就是说,狗的坐标x、y和对2取余是它的奇偶性,Dxy和对2取余是D的奇偶性。
    两个奇偶性一加再对2取余,拿这个余数去与剩下时间对2取余的余数作比较即可
    #include<iostream>
    #include<string.h>
    using namespace std;
    #include<math.h>
    char s[10][10];
    int ax,ay,bx,by,n,m,k;
    int t[4][2]={1,0,-1,0,0,1,0,-1},visit[10][10],flag;
    void dfs(int x,int y,int count)
    {
        int mx,my,i;
        if(x==bx&&y==by)
    {
        if(k==count){
        
        flag=1;
    }    
        return;
    }
       if(count>=k)
         return;
          if(s[x][y]!='X')
          {
              for(i=0;i<4;i++)
              {
                  mx=x+t[i][0];
                  my=y+t[i][1];
                  if(s[mx][my]!='X'&&mx>=1&&mx<=n&&my>=1&&my<=m&&!visit[mx][my])
                  {
                      visit[mx][my]=1;
                      dfs(mx,my,count+1);
                      visit[mx][my]=0;
                      if(flag)   //注意,在找到了目标之后,就不需要再找!以往编写dfs时,没有注意这点,就会超时 
                      return;
                  }
              }
          }
    }
    int main()
    {
        while(cin>>n>>m>>k)
        {
            if(n==0&&m==0&&k==0)
            return 0;
            int i,count=0;
            flag=0;
            for(i=1;i<=n;i++)
            {
                getchar();
                for(int j=1;j<=m;j++)
                {
                    cin>>s[i][j];
                    if(s[i][j]=='S')
                    {
                        ax=i;ay=j;
                    }
                    if(s[i][j]=='D')
                    {
                        bx=i;by=j;
                    }
                    
                }
            }
            getchar();
            memset(visit,0,sizeof(visit));
            if((abs(ax-bx)+abs(ay-by))>k||(ax+ay+bx+by+k)%2==1)//剪枝干 
            {
                //cout<<"*"<<endl;
                cout<<"NO"<<endl;
                continue;
            }
            visit[ax][ay]=1;
            count=0;
            dfs(ax,ay,count);
            if(flag==1)
            cout<<"YES"<<endl;
            else
            cout<<"NO"<<endl;  
        }
        return 0;
    }
    View Code
  • 相关阅读:
    《超越自己》--刘墉
    《菊与刀》--[美]鲁思·本尼迪克特(Ruth Benedict)
    《暧昧的日本人》--李兆忠
    《女性的选择》--[日]今野由梨
    《懂得低头,才能出头》--李艳
    原来还有这样的记词方法_Java版记不规则动词_博主推荐
    《永不止步》--[奥]力克胡哲
    C#面向服务WebService从入门到精通
    C# Windows服务开发从入门到精通
    sql server递归查询
  • 原文地址:https://www.cnblogs.com/xiechenxi/p/7845857.html
Copyright © 2011-2022 走看看