zoukankan      html  css  js  c++  java
  • poj1050 To the Max(降维dp)

    To the Max

    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 49351   Accepted: 26142

    Description

    Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
    As an example, the maximal sub-rectangle of the array: 

    0 -2 -7 0 
    9 2 -6 2 
    -4 1 -4 1 
    -1 8 0 -2 
    is in the lower left corner: 

    9 2 
    -4 1 
    -1 8 
    and has a sum of 15. 

    Input

    The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

    Output

    Output the sum of the maximal sub-rectangle.

    Sample Input

    4
    0 -2 -7 0 9 2 -6 2
    -4 1 -4  1 -1
    
    8  0 -2

    Sample Output

    15

    题意:

    求矩阵中和最大的子矩阵。

    思路:

    把题目转化成一维的最大连续子段和。

    枚举起始行i和终止行j,将i~j行的数对应相加,求解最大连续子段和。

    代码:

    #include<iostream>
    using namespace std;
    const int maxn = 105;
    int grap[maxn][maxn], sum[maxn][maxn];
    int main()
    {
        int n, tmp, ans=-0x3f3f3f3f;
        cin>>n;
        for(int i=1; i<=n; ++i)
        {
            for(int j=1; j<=n; ++j)
            {
                cin>>grap[i][j];
                sum[i][j]=sum[i-1][j]+grap[i][j];
            }
        }
        for(int i=1; i<=n; ++i)
        {
            for(int j=i; j<=n; ++j)
            {
                tmp=0;
                for(int k=1; k<=n; ++k)
                {
                    if(tmp<=0)
                        tmp=sum[j][k]-sum[i-1][k];
                    else
                        tmp+=sum[j][k]-sum[i-1][k];
                    ans=max(ans, tmp);
                }
            }
        }
        cout<<ans<<endl;
        return 0;
    }
  • 相关阅读:
    LPC2478中断控制器以及串口详解
    有效三角形的个数
    小于K的两数之和
    和至少为K的最短子数组
    docker: 构建自己的镜像
    判断字符串是否是异位词
    找出字符串中的最长回文
    knuth洗牌算法
    使用adb命令控制anroid手机
    bitmap以及异或运算法
  • 原文地址:https://www.cnblogs.com/xiepingfu/p/7265682.html
Copyright © 2011-2022 走看看