zoukankan      html  css  js  c++  java
  • poj1655 Balancing Act (dp? dfs?)

    Balancing Act

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 14247   Accepted: 6026

    Description

    Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T. 
    For example, consider the tree: 

    Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two. 

    For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number. 

    Input

    The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

    Output

    For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

    Sample Input

    1
    7
    2 6
    1 2
    1 4
    4 5
    3 7
    3 1
    

    Sample Output

    1 2

    题意:

    找树的重心,即:
    定义1:找到一个点,其所有的子树中最大的子树节点数最少,那么这个点就是这棵树的重心。
    定义2:以这个点为根,那么所有的子树(不算整个树自身)的大小都不超过整个树大小的一半。
    性质1:树中所有点到某个点的距离和中,到重心的距离和是最小的;如果有两个重心,那么他们的距离和一样。
    性质2:把两个树通过一条边相连得到一个新的树,那么新的树的重心在连接原来两个树的重心的路径上。
    性质3:把一个树添加或删除一个叶子,那么它的重心最多只移动一条边的距离。

    思路:

    选取任意节点为根节点,dfs求当前节点所代表的子树的节点总数(包含自己记为sum)和该节点的所有子树中节点数最大值(记为ave)。则依据题意,删除当前节点后的平衡值为

    max(n-sum,ave);找到最小值输出。

    看到别人说是dp,可能我不会dp。

    代码:

    #include<iostream>
    #include<cstdio>
    #include<vector>
    using namespace std;
    const int maxn = 2e4+4, INF = 0x3f3f3f3f;
    
    vector<int> grap[maxn];
    int vis[maxn], sum[maxn], ave[maxn];
    int t, n;
    
    int dfs(int x)
    {
        int res=1;
        for(int i=0; i<grap[x].size(); ++i)
        {
            int xx=grap[x][i];
            if(vis[xx]) continue;
            vis[xx]=1;
            int kk=dfs(xx);
            ave[x]=max(ave[x], kk);
            res+=kk;
            vis[xx]=0;
        }
        sum[x]=res;
        ave[x]=max(ave[x], n-sum[x]);
        return res;
    }
    
    int main()
    {
        ios::sync_with_stdio(false);
        cin.tie(0);
        cout.tie(0);
        cin>>t;
        while(t--)
        {
            cin>>n;
            for(int i=1; i<=n; ++i)
            {
                grap[i].clear();
                vis[i]=0;
                sum[i]=0;
                ave[i]=0;
            }
            for(int i=2; i<=n; ++i)
            {
                int u, v;
                cin>>u>>v;
                grap[u].push_back(v);
                grap[v].push_back(u);
            }
            vis[1]=1;
            dfs(1);
            int ans=INF, v=0;
            for(int i=1; i<=n; ++i)
                if(ans>ave[i])
                    ans=ave[i], v=i;
            cout<<v<<" "<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    转:C#操作摄像头
    C# Memcached缓存
    WCF:调用方未由服务器进行身份验证
    SQL Server 存储过程进行分页查询
    SQL Server T-SQL高级查询
    C#设计模式总结(转)
    C#中构造函数和析构函数区别
    C#: static关键字的作用(转)
    C#结构体和类的区别(转)
    .NET多线程编程(转)
  • 原文地址:https://www.cnblogs.com/xiepingfu/p/7280150.html
Copyright © 2011-2022 走看看