zoukankan      html  css  js  c++  java
  • sicily 1036. Crypto Columns

    Constraints

    Time Limit: 1 secs, Memory Limit: 32 MB 

    Description

    The columnar encryption scheme scrambles the letters in a message (or plaintext) using a keyword as illustrated in the following example: Suppose BATBOY is the keyword and our message is MEET ME BY THE OLD OAK TREE. Since the keyword has 6 letters, we write the message (ignoring spacing and punctuation) in a grid with 6 columns, padding with random extra letters as needed:

    MEETME
    BYTHEO
    LDOAKT
    REENTH

    Here, we've padded the message with NTH. Now the message is printed out by columns, but the columns are printed in the order determined by the letters in the keyword. Since A is the letter of the keyword that comes first in the alphabet, column 2 is printed first. The next letter, B, occurs twice. In the case of a tie like this we print the columns leftmost first, so we print column 1, then column 4. This continues, printing the remaining columns in order 5, 3 and finally 6. So, the order the columns of the grid are printed would be 2, 1, 4, 5, 3, 6, in this case. This output is called the ciphertext, which in this example would be EYDEMBLRTHANMEKTETOEEOTH. Your job will be to recover the plaintext when given the keyword and the ciphertext.

    Input

    There will be multiple input sets. Each set will be 2 input lines. The first input line will hold the keyword, which will be no longer than 10 characters and will consist of all uppercase letters. The second line will be the ciphertext, which will be no longer than 100 characters and will consist of all uppercase letters. The keyword THEEND indicates end of input, in which case there will be no ciphertext to follow.

    Output

    For each input set, output one line that contains the plaintext (with any characters that were added for padding). This line should contain no spacing and should be all uppercase letters.

    Sample Input

    BATBOY
    EYDEMBLRTHANMEKTETOEEOTH
    HUMDING
    EIAAHEBXOIFWEHRXONNAALRSUMNREDEXCTLFTVEXPEDARTAXNAARYIEX
    THEEND

    Sample Output

    MEETMEBYTHEOLDOAKTREENTH
    ONCEUPONATIMEINALANDFARFARAWAYTHERELIVEDTHREEBEARSXXXXXX

    注意是将已经转换过的序列恢复原状。只需要将原来的转换规则逆向就可以。

    #include <iostream>
    #include <string>
    #include <map>
    #include <vector>
    using namespace std;
    
    int main(int argc, char *argv[])
    {
        string keyWorld;
        string message;
    
        while (cin >> keyWorld && keyWorld != "THEEND") {
            cin >> message;
    
            multimap<char, int> keyOrder;
            int eachRowNum = keyWorld.size();
    
            for (int i = 0; i != eachRowNum; ++i) {
                keyOrder.insert(pair<char, int>(keyWorld[i], i));
            }
    
            int colNum = message.size() / eachRowNum;
    
            vector<string> result;
            for (int i = 0; i != eachRowNum; i++) {
                result.push_back(message.substr(i * colNum, colNum));
            }
            int index = 0;
            int re[10];
            for (multimap<char, int>::iterator iter = keyOrder.begin(); 
                                        iter != keyOrder.end(); ++iter) {
                    re[iter->second] = index++;
            }
    
            for (int i = 0; i != colNum; ++i) {
                for (int j = 0; j != eachRowNum; ++j) {
                    cout << result[re[j]][i];
                }
            }
            cout << endl;
        }
    
        return 0;
    }
  • 相关阅读:
    ftp如果有文件夹直接建文件,没有创建文件夹
    jfinal相关
    jfinal多数据源
    创建maven项目多模块项目
    多线程分批处理list内的值
    内部类_常见的用途
    获取aplicationContext对象,从而获取任何注入的对象
    jquery表单验证
    monkeyrunner录制回放
    android稳定性测试
  • 原文地址:https://www.cnblogs.com/xiezhw3/p/4007094.html
Copyright © 2011-2022 走看看