zoukankan      html  css  js  c++  java
  • sicily 1240. Faulty Odometer

    Description
    You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 3 to the digit 5, always skipping over the digit 4. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15339 and the car travels one mile, odometer reading changes to 15350 (instead of 15340).
    Input
    Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 4.
    Output
    Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car. 
    Sample Input
     Copy sample input to clipboard 
    13
    15
    2003
    2005
    239
    250
    1399
    1500
    999999
    0
    
    
    Sample Output
    13: 12
    15: 13
    2003: 1461
    2005: 1462
    239: 197
    250: 198
    1399: 1052
    1500: 1053
    999999: 531440
    
    分析:根据题目,在十进制里面去掉了4,那么也就是变成了9进制。然后因为跳过了4,那么大于4的值显然就应该减1
    #include <iostream>
    #include <cmath>
    
    using namespace std;
    
    int main(int argc, char const *argv[])
    {
        int number, numT;
        while (cin >> number && number != 0) {
            numT = number;
            int k = 0;
            int result = 0;
            while (number) {
                int t = number % 10;
                t = t >= 5 ? t - 1 : t;
                result += t * pow(9, k++);
                number /= 10;
            }
            cout << numT << ": " << result << endl;
        }
        return 0;
    }
  • 相关阅读:
    [湖北省队互测2014] 没有人的算术 (非题解)
    普及常见图论算法整理
    普及常见数据结构板子整理
    Pisano Period
    退役了
    LOJ3246 「USACO 2020.1 Platinum」Cave Paintings
    LOJ3193 「ROI 2019 Day2」机器人高尔夫球赛
    LOJ3192 「ROI 2019 Day2」课桌
    LOJ6496 「雅礼集训 2018 Day1」仙人掌
    Luogu P4518 [JSOI2018]绝地反击
  • 原文地址:https://www.cnblogs.com/xiezhw3/p/4104488.html
Copyright © 2011-2022 走看看