zoukankan      html  css  js  c++  java
  • sicily 1388. Quicksum

    Description

    A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

    For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

    A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":

            ACM: 1*1  + 2*3 + 3*13 = 46
    MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650
     
    Input
    The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters. 
    Output
    For each packet, output its Quicksum on a separate line in the output. 
    Sample Input
     Copy sample input to clipboard 
    ACM
    MID CENTRAL
    REGIONAL PROGRAMMING CONTEST
    ACN
    A C M
    ABC
    BBC
    #
    Sample Output
    46
    650
    4690
    49
    75
    14
    15
    分析:前面用 255 wa了,改成256 ac了,肯能题目描述得有点不太清楚。。
    #include <iostream>
    #include <string>
    #include <map>
    
    using namespace std;
    
    char letters[27] = {
        ' ', 'A', 'B', 'C', 'D', 'E', 'F',
        'G', 'H', 'I', 'J', 'K', 'L', 'M',
        'N', 'O', 'P', 'Q', 'R', 'S', 'T',
        'U', 'V', 'W', 'X', 'Y', 'Z'
    };
    
    int main(int argc, char const *argv[])
    {
        char str[256];
        map<char , int> mapLetter;
        for (int i = 0; i != 27; ++i) {
            mapLetter[letters[i]] = i;
        }
    
        while (cin.getline(str, 256, '
    ') && str[0] != '#') {
            int sum = 0;
            
            for (int i = 0; i != 256; ++i) {
                if (str[i] == '')
                    break;
                sum += mapLetter[str[i]] * (i + 1);
            }
            cout << sum << endl;
        }
        return 0;
    }
  • 相关阅读:
    Linux dnsmasq.conf
    Linux 关闭网络管理服务
    Python Mysql_db对数据查询进行处理
    Python windows安装MYSQL_db
    Python 递归
    Nginx 系统维护配置
    ls 查看时间排序
    Nginx Linux yum安装
    Nginx 前后端分离配置 分发
    Spring boot 执行jar文件 方式
  • 原文地址:https://www.cnblogs.com/xiezhw3/p/4132838.html
Copyright © 2011-2022 走看看