zoukankan      html  css  js  c++  java
  • POJ 1014 Dividing(多重背包, 倍增优化)

    Q: 倍增优化后, 还是有重复的元素, 怎么办

    A: 假定重复的元素比较少, 不用考虑

    Description

    Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

    Input

    Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
    The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

    Output

    For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
    Output a blank line after each test case.

    Sample Input

    1 0 1 2 0 0 
    1 0 0 0 1 1 
    0 0 0 0 0 0 

    Sample Output

    Collection #1:
    Can't be divided.
    
    Collection #2:
    Can be divided.

    思路:

    1. 倍增优化, 将 n 转化成 1, 2, 4 ..2^i , (n-前面的和), 然后应用 01背包问题处理

    总结:

    1. 判断恰好装满的条件为 dp[V] == V. 因为未初始化为 INF, 初始化为 INF 有个好处, 就是可以直接返回 dp[V], 但是更新 dp[v] 时需要加 dp[v] == inf 的判断

    代码:

    #include <iostream>
    using namespace std;
    int w[10];
    int marble[10000];
    int totalWeight;
    int dp[120000];
    int solve_dp() {
    	
    	int len = 0;
    	for(int i = 1; i <= 6; i ++) {
    		int sum = 0;
    		for(int j = 0;; j ++) {
    			if(sum + (1<<j) > w[i])
    				break;
    			marble[len++] = (1<<j)*i;
    			sum += (1<<j);
    		}
    		if(sum < w[i])
    			marble[len++] = (w[i]-sum)*i;
    	}
    	memset(dp, 0, totalWeight*sizeof(int));
    	// 01 背包
    	int V = totalWeight>>1;
    	dp[0] = 0;
    	for(int i = 0; i < len; i ++) {
    		for(int v = V; v >= marble[i]; v--) {
    			dp[v] = max(dp[v], dp[v-marble[i]]+marble[i]);
    		}
    	}
    	return (dp[V]==V);
    }
    int main() {
    	freopen("E:\Copy\ACM\测试用例\in.txt", "r", stdin);
    	int tc = 0;
    	do {
    		int sum = 0;
    		for(int i = 1; i <= 6; i ++) {
    			scanf("%d", &w[i]);
    			sum += w[i]*i;
    		}
    		if(sum == 0)
    			return 0;
    		tc ++;
    		if(sum & 1) { // 为奇数 
    			printf("Collection #%d:
    Can't be divided.
    
    ", tc);
    			continue;
    		}
    		// 重建 model, 转移成 01 背包问题
    		totalWeight = sum;
    		int ans = solve_dp();
    		if(!ans)
    			printf("Collection #%d:
    Can't be divided.
    
    ", tc);
    		else
    			printf("Collection #%d:
    Can be divided.
    
    ", tc);
    	}while(1);
    	return 0;
    }
    

      

  • 相关阅读:
    看了陈安之的文字 无论怎样 都要记住的是 你仍然是你自己 改变是应用他人的方法提高自己 改变是做更优秀更独特的自己
    流行的Ajax应用演示和源码下载(转)
    WEB2.0概念诠释(根据网络资料归纳)之一
    ASP.NET中文件上传下载方法集合(较为详细的介绍 转)
    建立梦想清单
    Ajax的应用
    Ajax的问题
    WEB2.0概念诠释(根据网络资料归纳)之三
    IIS突然挂掉
    VS2008软件90天过期,解决升级问题。
  • 原文地址:https://www.cnblogs.com/xinsheng/p/3463686.html
Copyright © 2011-2022 走看看