zoukankan      html  css  js  c++  java
  • POJ 3258 River Hopscotch(二分法搜索)

    Description

    Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

    To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

    Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

    FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

    Input

    Line 1: Three space-separated integers: LN, and M 
    Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

    Output

    Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

    Sample Input

    25 5 2
    2
    14
    11
    21
    17

    Sample Output

    4

    Hint

    Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
     
    思路
    1. 二分法
     
    代码
    Source Code
    
    Problem: 3258        User: blazing
    Memory: 424K        Time: 157MS
    Language: C++        Result: Accepted
    Source Code
    #include <iostream>
    #include <stdio.h>
    #include <algorithm>
    using namespace std;
    const int MAXN = 50010;
    int L, N, M;
    int rocks[MAXN];
    
    int binarySearch(int low, int high) {
        while( low <= high ) {
            int count = 0, lastPos = 0;
            int mid = ( low + high ) >> 1;
            //cout << "mid : " << mid << endl;
            for( int i = 1; i <= N+1; i ++ ) {
                if( rocks[i] - rocks[lastPos] < mid ) {
                    // move one rock to extend the distance
                    count += 1;
                }else {
                    lastPos = i;
                }
            }
    
            if (count > M)
                high = mid - 1;
            else
                low = mid + 1;
        }
        return high;
    }
    
    int main() {
        //freopen("E:\Copy\ACM\poj\3258_v2\in.txt", "r", stdin);
        while( cin >> L >> N >> M ) {
            int low = 0x3FFFFFFF;
            memset( rocks, 0, sizeof(rocks));
            for( int i = 1; i <= N; i ++ ) {
                scanf("%d", &rocks[i]);
            }
            rocks[0] = 0, rocks[N+1] = L;
            sort( rocks, rocks+N+2);
            
    
            for(int i = 1; i <= N+1; i++) {
                low = min ( low, rocks[i]-rocks[i-1] );
            }
            
            cout << binarySearch( low, L ) << endl;
        }
        return 0;
    }
  • 相关阅读:
    bootstrap添加模态窗后,再弹出消息提示框后,原先的滚动条消失
    改变input[type=file]的默认样式
    javascript判断访问终端,手机端自动跳转
    sublime安装插件autoprefixer
    android 自动化压力测试-monkey 1 实践
    python 网络编程-TCP/UDP
    python 正则表达式
    Python 读写excel数据
    Python 删除列表中的重复数据
    Python python 基本语法
  • 原文地址:https://www.cnblogs.com/xinsheng/p/3599765.html
Copyright © 2011-2022 走看看