zoukankan      html  css  js  c++  java
  • 【每天一道PAT】1006 Sign In and Sign Out

    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:

    Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time

    where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

    Output Specification:

    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

    Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:

    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40
    

    Sample Output:

    SC3021234 CS301133
    

    思路

    定义结构体数组,分别读取每个学生的id和进入离开时间,将时间排序找到对应学号并输出

    代码

    #include <cstdio>
    #include <algorithm>
    using namespace std;
    struct node{
        char id[16];
        int in_time = 0;
        int out_time = 0;
    }stu[1000];
    bool cmp1(node a, node b)
    {
        return a.in_time<b.in_time;
    }
    bool cmp2(node a, node b)
    {
        return a.out_time>b.out_time;
    }
    int main()
    {
        int N;//学生人数
        int h1,h2, m1,m2, s1,s2;
        scanf("%d", &N);
        for (int i = 0; i < N; ++i)
        {
              scanf("%s %d:%d:%d", stu[i].id,&h1,&m1,&s1);
              stu[i].in_time = h1*3600+m1*60+s1;
              scanf("%d:%d:%d",&h2,&m2,&s2);
              stu[i].out_time = h2*3600+m2*60+s2;
        }
        sort(stu,stu+N,cmp1);//排序找到进入时间最小的学号
        printf("%s ", stu[0].id);
        sort(stu,stu+N,cmp2);//排序找到离开时间最大的学号
        printf("%s", stu[0].id);
    
    }
    
    
    

  • 相关阅读:
    系统升级到9.10感觉很不错
    mysql数据库文件坏掉后通过二进值日志恢复
    关于杨宪益传
    Linux下设置屏幕亮度
    XFCE升级到4.10
    在Linux下编译安装php
    Ubuntu unity安装IndicatorMultiload
    解析Visual Studio Unit Test Result文件(trx文件)
    Linux下安装wordpress3.4
    XFCE字体发虚的解决方法
  • 原文地址:https://www.cnblogs.com/xinyuLee404/p/12644189.html
Copyright © 2011-2022 走看看