zoukankan      html  css  js  c++  java
  • HDU1702:ACboy needs your help again!

    Problem Description
    ACboy was kidnapped!!  
    he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
    As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
    The problems of the monster is shown on the wall:
    Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
    and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
    and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
     
    Input
    The input contains multiple test cases.
    The first line has one integer,represent the number oftest cases.
    And the input of each subproblem are described above.
     
    Output
    For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
     
    Sample Input
    4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT
     
    Sample Output
    1 2 2 1 1 2 None 2 3
     


     

    //

    赤裸裸的栈和队列的应用

    #include <iostream>
    #include <cstdio>
    #include <string.h>
    #include <queue>
    #include <stack>
    using namespace std;
    
    void que_ex(int n)
    {
        queue<int> Q;
        char s[10];
        int a;
        while(n--)
        {
            scanf("%s",s);
            if(!strcmp(s,"IN"))
            {
                scanf("%d",&a);
                Q.push(a);
            }
            else if(!strcmp(s,"OUT"))
            {
                if(Q.empty())
                    printf("None\n");
                else
                {
                    printf("%d\n",Q.front());
                    Q.pop();
                }
            }
        }
    }
    
    void sta_ex(int n)
    {
        stack<int> S;
        char s[10];
        int a;
        while(n--)
        {
            scanf("%s",s);
            if(!strcmp(s,"IN"))
            {
                scanf("%d",&a);
                S.push(a);
            }
            else if(!strcmp(s,"OUT"))
            {
                if(S.empty())
                    printf("None\n");
                else
                {
                    printf("%d\n",S.top());
                    S.pop();
                }
            }
        }
    }
    
    int main()
    {
        int n;
        while(~scanf("%d",&n))
        {
            while(n--)
            {
                int m;
                char str[100];
                scanf("%d%s",&m,str);
                if(!strcmp(str,"FIFO"))
                    que_ex(m);
                else if(!strcmp(str,"FILO"))
                    sta_ex(m);
                else
                    printf("error\n");
            }
        }
    
        return 0;
    }
    


     

  • 相关阅读:
    【Spring】 AOP Base
    【Offer】[20] 【表示数值的字符串】
    【Offer】[19] 【字符串匹配】
    【设计模式】代理模式
    【LeetCode】[0002] 【两数之和】
    【Offer】[18-1] 【在O(1)时间内删除链表节点】
    【Offer】[18-2] 【删除链表中重复的节点】
    【Offer】[17] 【打印1到最大的n位数】
    【Offer】[16] 【数值的整数次方】
    python_内置函数
  • 原文地址:https://www.cnblogs.com/xinyuyuanm/p/2990645.html
Copyright © 2011-2022 走看看