zoukankan      html  css  js  c++  java
  • 杭电OJ——1032 The 3n + 1 problem

    The 3n + 1 problem

    Problem Description
    Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

    Consider the following algorithm: 


        1.      input n

        2.      print n

        3.      if n = 1 then STOP

        4.           if n is odd then n <- 3n + 1

        5.           else n <- n / 2

        6.      GOTO 2


    Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 

    It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

    Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

    For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 
     
    Input
    The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0. 

    You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j. 

    You can assume that no opperation overflows a 32-bit integer.
     
    Output
    For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line). 
     
    Sample Input
    1 10 100 200 201 210 900 1000
     
    Sample Output
    1 10 20 100 200 125 201 210 89 900 1000 174
     
    Source
    UVA
     
    Recommend
    mcqsmall
     
             问题直接用暴力法就可以解出来,唯一要注意的一点就是i不一定小于j。
          代码如下:
    #include <iostream>
    #include <cstdio>
    using namespace std;
    
    int inline countTimes(int n)
    {
    	int times = 1;
    	do
    	{
    		if(n & 0x1 == 1)
    		{
    			n = 3 * n + 1;
    		}
    		else
    		{
    			n = n >> 1;
    		}
    		++times;
    	}while(n != 1);
    	return times;
    }
    int main()
    {
    	int i, j;
    	while (scanf ("%d%d", &i, &j) != EOF)
    	{
    		int bi1, bi2, bi3;
    		if (i > j)
    		{
    			bi1 = j;
    			bi2 = i;
    		}
    		else
    		{
    			bi1 = i;
    			bi2 = j;
    		}
    		int maxTimes;
    		maxTimes = countTimes (i);
    		for (int k = bi1 + 1; k <= bi2; k++)
    		{
    			bi3 = countTimes(k);
    			if (bi3 > maxTimes)
    			maxTimes = bi3;
    		}
    		cout << i << ' ' << j << ' ' << maxTimes << endl;
    
    	}
    	system ("pause");
    	return 0;
    
    }


  • 相关阅读:
    Array总结
    js 添加收藏
    js 浮点数
    chrome 不支持 input file cursor:pointer
    nginx proxy_set_header设置、自定义header
    docker常用命令
    ssh登录问题解决
    android10 搜索不到ble设备的问题解决
    go语言接口型函数使用
    树莓派gpio驱动
  • 原文地址:https://www.cnblogs.com/xinyuyuanm/p/3177696.html
Copyright © 2011-2022 走看看