zoukankan      html  css  js  c++  java
  • [并查集] More is Better

    题目描述

    Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

    输入

    The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

    输出

    The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

    样例输入

    3 1 3 1 5 2 5 4 3 2 3 4 1 6 2 6

    样例输出

    4 5
     
    #include <iostream>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    using namespace std;
    
    int f[10000001];
    int num[10000001];
    
    int findFather(int x)
    {
        int a=x;
        while(x!=f[x])
        {
            x=f[x];
        }
        while(a!=f[a])
        {
            int z=a;
            a=f[a];
            f[z]=x;
        }
        return x;
    }
    int ans=1;
    void unionf(int a,int b)
    {
        int fa=findFather(a);
        int fb=findFather(b);
        if(fa!=fb)
        {
            f[fa]=fb;
            num[fb]=num[fa]+num[fb];
            if(num[fb]>ans)
            {
                ans=num[fb];
            }
        }
    }
    
    void init()
    {
        for(int i=0;i<10000001;i++)
        {
            f[i]=i;
            num[i]=1;
        }
    }
    
    int main()
    {
        int n;
        while(cin>>n)
        {
            init();
            int a,b;
            ans=1;
            for(int i=0;i<n;i++)
            {
                cin>>a>>b;
                unionf(a,b);
                //cout<<"ans:"<<ans<<endl;
            }
            cout<<ans<<endl;
        }
        return 0;
    }
     
  • 相关阅读:
    存储过程与触发器的区别
    WebDriver基本操作入门及UI自动化练手页面
    第四章 TestNG测试用例分步解析(上)
    第三章 Webdriver Java API简介(下)
    第三章 Webdriver Java API简介(上)
    第二章 TestNG环境搭建
    第一章 TestNG框架自动化简述
    基于Selenium2和TestNG的自动化测试
    程序员都应该知道的福利
    TestNG系列教程:并行执行测试
  • 原文地址:https://www.cnblogs.com/xiongmao-cpp/p/6433398.html
Copyright © 2011-2022 走看看