zoukankan      html  css  js  c++  java
  • [图算法] 1003. Emergency (25)

    As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

    Input

    Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

    Output

    For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
    All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

    Sample Input

    5 6 0 2
    1 2 1 5 3
    0 1 1
    0 2 2
    0 3 1
    1 2 1
    2 4 1
    3 4 1
    

    Sample Output

    2 4
    #include <iostream>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    using namespace std;
    const int maxn=510;
    const int INF=1e9;
    
    int g[maxn][maxn];
    int n,m,st,dt;
    int d[maxn]={0};
    int weight[maxn];
    bool vis[maxn]={false};
    int w[maxn];
    int num[maxn]={0};
    
    void dijkstra(int s)
    {
        fill(d,d+maxn,INF);
        fill(w,w+maxn,0);
        d[s]=0;
        w[s]=weight[s];
        num[s]=1;
        for(int i=0;i<n;i++)
        {
            int u=-1,MIN=INF;
            for(int j=0;j<n;j++)
            {
                if(vis[j]==false&&d[j]<MIN)
                {
                    u=j;
                    MIN=d[j];
                } 
            }
            if(u==-1) return ;
            
            vis[u]=true;
            for(int v=0;v<n;v++)
            {
                if(vis[v]==false&&g[u][v]!=INF)
                {
                    if(d[u]+g[u][v]<d[v])
                    {
                        d[v]=d[u]+g[u][v];
                        w[v]=w[u]+weight[v];
                        num[v]=num[u];
                    }
                    else if(d[u]+g[u][v]==d[v])
                    {
                        if(w[v]<w[u]+weight[v])
                        {
                            w[v]=w[u]+weight[v];
                        }
                        num[v]+=num[u];
                    }
                }
            }
        }
    }
    
    int main()
    {
        fill(g[0],g[0]+maxn*maxn,INF);
        cin>>n>>m>>st>>dt;
        for(int i=0;i<n;i++) cin>>weight[i];
        for(int i=0;i<m;i++)
        {
            int id1,id2,cost;
            cin>>id1>>id2>>cost;
            g[id1][id2]=cost;
            g[id2][id1]=cost;
        }
        dijkstra(st);
        cout<<num[dt]<<" "<<w[dt]<<endl;
    }
  • 相关阅读:
    配置变量的信息
    Smarty保留变量信息
    选择排序
    java.utils.HashMap数据结构分析
    HashMap的工作原理
    Dubbo
    五种单例模式:
    Redis的持久化机制包括RBD和AOF两种,对于这两种持久化方式各有优势
    Zookeeper要安装在奇数个节点,但是为什么?
    Redis搭建多台哨兵
  • 原文地址:https://www.cnblogs.com/xiongmao-cpp/p/6440026.html
Copyright © 2011-2022 走看看