zoukankan      html  css  js  c++  java
  • [图算法] 1003. Emergency (25)

    As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

    Input

    Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

    Output

    For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
    All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

    Sample Input

    5 6 0 2
    1 2 1 5 3
    0 1 1
    0 2 2
    0 3 1
    1 2 1
    2 4 1
    3 4 1
    

    Sample Output

    2 4
    #include <iostream>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    using namespace std;
    const int maxn=510;
    const int INF=1e9;
    
    int g[maxn][maxn];
    int n,m,st,dt;
    int d[maxn]={0};
    int weight[maxn];
    bool vis[maxn]={false};
    int w[maxn];
    int num[maxn]={0};
    
    void dijkstra(int s)
    {
        fill(d,d+maxn,INF);
        fill(w,w+maxn,0);
        d[s]=0;
        w[s]=weight[s];
        num[s]=1;
        for(int i=0;i<n;i++)
        {
            int u=-1,MIN=INF;
            for(int j=0;j<n;j++)
            {
                if(vis[j]==false&&d[j]<MIN)
                {
                    u=j;
                    MIN=d[j];
                } 
            }
            if(u==-1) return ;
            
            vis[u]=true;
            for(int v=0;v<n;v++)
            {
                if(vis[v]==false&&g[u][v]!=INF)
                {
                    if(d[u]+g[u][v]<d[v])
                    {
                        d[v]=d[u]+g[u][v];
                        w[v]=w[u]+weight[v];
                        num[v]=num[u];
                    }
                    else if(d[u]+g[u][v]==d[v])
                    {
                        if(w[v]<w[u]+weight[v])
                        {
                            w[v]=w[u]+weight[v];
                        }
                        num[v]+=num[u];
                    }
                }
            }
        }
    }
    
    int main()
    {
        fill(g[0],g[0]+maxn*maxn,INF);
        cin>>n>>m>>st>>dt;
        for(int i=0;i<n;i++) cin>>weight[i];
        for(int i=0;i<m;i++)
        {
            int id1,id2,cost;
            cin>>id1>>id2>>cost;
            g[id1][id2]=cost;
            g[id2][id1]=cost;
        }
        dijkstra(st);
        cout<<num[dt]<<" "<<w[dt]<<endl;
    }
  • 相关阅读:
    cordova热更新插件的使用:cordova-hot-code-push-plugin
    cordova日期插件的使用:cordova-plugin-datepicker
    前后端如何保持长连接?---websocket
    ionic使用的一些技巧
    ionic 前端接收到后台推送来的消息后,显示在手机的通知栏上
    gbk和utf8的json转化
    short_open_tag的作用
    查询时间段内各个城市每天订单量,并按照城市、日期倒序排序
    msyql常用函数
    微信小程序简单开发流程
  • 原文地址:https://www.cnblogs.com/xiongmao-cpp/p/6440026.html
Copyright © 2011-2022 走看看