zoukankan      html  css  js  c++  java
  • [图算法] 1030. Travel Plan (30)

    1030. Travel Plan (30)

    A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

    City1 City2 Distance Cost

    where the numbers are all integers no more than 500, and are separated by a space.

    Output Specification:

    For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

    Sample Input
    4 5 0 3
    0 1 1 20
    1 3 2 30
    0 3 4 10
    0 2 2 20
    2 3 1 20
    
    Sample Output
    0 2 3 3 40
    #include <iostream>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    using namespace std;
    
    const int maxn=510;
    const int INF=1e9;
    
    int n,m,s,den;
    int G[maxn][maxn],cost[maxn][maxn];
    int d[maxn];
    int c[maxn];
    bool vis[maxn];
    int pre[maxn];
    
    void dijstra(int begin)
    {
        fill(d,d+maxn,INF);
        fill(c,c+maxn,INF);
        fill(vis,vis+maxn,false);
        for(int i=0;i<n;i++) pre[i]=i;
        d[begin]=0;
        c[begin]=0;
        pre[begin]=begin;
        for(int i=0;i<n;i++)
        {
            int u=-1,MIN=INF;
            for(int j=0;j<n;j++)
            {
                if(vis[j]==false&&d[j]<MIN)
                {
                    u=j;
                    MIN=d[j];
                }
            }
            if(u==-1) return ;
            vis[u]=true;
            for(int v=0;v<n;v++)
            {
                if(vis[v]==false&&G[u][v]!=INF)
                {
                    if(d[u]+G[u][v]<d[v])
                    {
                        d[v]=d[u]+G[u][v];
                        c[v]=c[u]+cost[u][v];
                        pre[v]=u;
                    }
                    else if(d[u]+G[u][v]==d[v])
                    {
                        if(c[u]+cost[u][v]<c[v])
                        {
                            c[v]=c[u]+cost[u][v];
                            pre[v]=u;
                        }
                    }
                }
            }
        }
    }
    
    void printPath(int k)
    {
        if(k==s)
        {
            printf("%d ",k);
            return ;
        }
        printPath(pre[k]);
        printf("%d ",k);
    }
    
    int main()
    {
        cin>>n>>m>>s>>den;
        int city1,city2,dist,co;
        fill(G[0],G[0]+maxn*maxn,INF);
        for(int i=0;i<m;i++)
        {
            cin>>city1>>city2>>dist>>co;
            G[city1][city2]=dist;
            G[city2][city1]=dist;
            cost[city1][city2]=co;
            cost[city2][city1]=co;
        }
        dijstra(s);
        printPath(den);
        cout<<d[den]<<" "<<c[den]<<endl;
    }
  • 相关阅读:
    Asp.net MVC 自定义路由在IIS7以上,提示Page Not Found 解决方法
    mysql 常用操作
    Mongo常用操作
    Cent Os 常用操作
    Window 8.1 开启Wifi共享
    解决 对象的当前状态使该操作无效 的问题
    unity3d: how to display the obj behind the wall
    unreal network
    rust borrow and move
    erlang的map基本使用
  • 原文地址:https://www.cnblogs.com/xiongmao-cpp/p/6440109.html
Copyright © 2011-2022 走看看