zoukankan      html  css  js  c++  java
  • ACM Registration system

    Registration system

    时间限制:1000 ms  |  内存限制:65535 KB
    难度:2
     
    描述

    A new e-mail service "Berlandesk" is going to be opened in Berland in the near future.

     The site administration wants to launch their project as soon as possible, that's why they

     ask you to help. You're suggested to implement the prototype of site registration system. 

    The system should work on the following principle.

    Each time a new user wants to register, he sends to the system a request with his name.

     If such a name does not exist in the system database, it is inserted into the database, and 

    the user gets the response OK, confirming the successful registration. If the name already 

    exists in the system database, the system makes up a new user name, sends it to the user 

    as a prompt and also inserts the prompt into the database. The new name is formed by the

     following rule. Numbers, starting with 1, are appended one after another to name (name1,

     name2, ...), among these numbers the least i is found so that namei does not yet exist in

     the database.

     
    输入
    The first line contains number n (1 ≤ n ≤ 105). The following n lines contain the requests to the system. Each request is a non-empty line, and consists of not more than 1000 characters, which are all lowercase Latin letters.
    输出
    Print n lines, which are system responses to the requests: OK in case of successful registration, or a prompt with a new name, if the requested name is already taken.
    样例输入
    4
    abacaba
    acaba
    abacaba
    acab
    
    样例输出
    OK
    OK
    abacaba1
    OK
    #include <iostream>
    #include <vector>
    #include <string>
    #include <map>
    using namespace std;
    
    int main(){
        int n;
        cin >> n;
        map<string,int> nameMap;
        while(n--){
            string str;
            cin >>str;
            if(nameMap.find(str)==nameMap.end()){
                nameMap.insert(make_pair(str,0));
                cout<<"OK"<<endl;
            }else{
                nameMap[str]++;
                cout<<str<<nameMap[str]<<endl;
            }
        }
    }
  • 相关阅读:
    最简单的界面建立
    滚动字幕的建立(事件的监听,定时器)
    【转】centOS上安装redis+phpredis2.2.4扩展
    【转】文件恢复神器extundelete
    CentOS 漏洞修补
    [转]给Linux系统管理员准备的Nmap命令的29个实用范例+ tsysv 系统服务器管理器
    [转]linux下iftop工具的安装与使用详解(图文)——实时的网络流量,监控TCP/IP连接(单机)
    [转]tripwire-文件指纹
    [转]svn提交自动同步到web服务器
    [转]CentOS_yum的详细使用方法
  • 原文地址:https://www.cnblogs.com/xiongqiangcs/p/3674380.html
Copyright © 2011-2022 走看看