zoukankan      html  css  js  c++  java
  • ACM blockhouses

    blockhouses

    时间限制:1000 ms  |  内存限制:65535 KB
    难度:3
     
    描述
    Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

    A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

    Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

    The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

    The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



    Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
     
    输入
    The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.
    输出
    For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
    样例输入
    4
    .X..
    ....
    XX..
    ....
    2
    XX
    .X
    3
    .X.
    X.X
    .X.
    3
    ...
    .XX
    .XX
    4
    ....
    ....
    ....
    ....
    0
    样例输出
    5
    1
    5
    2
    4
    #include <iostream>
    #include <string>
    #include <vector>
    #include <algorithm>
    #include <iterator>
    #include <utility>
    using namespace std;
    typedef pair<int,int> Point;
    int ans = 0;
    
    bool check(vector<string>& blockhouse,Point p){
        for(int i = p.first; i>=0; --i){
            if(blockhouse[i][p.second] == 'X') break;
            if(blockhouse[i][p.second] == '*') return false;
        }
        for(int i = p.second; i >= 0; -- i){
            if(blockhouse[p.first][i] == 'X') break;
            if(blockhouse[p.first][i] == '*') return false;
        }
        return true;
    }
    
    void dfs(vector<string>& blockhouse,Point pos,int sum ){
        int n = blockhouse.size();
        if(ans < sum) ans = sum;
        if(pos.second == n) {pos.first++;pos.second =0;}
        if(pos.first == n && pos.second == 0) return;
        if(blockhouse[pos.first][pos.second] == 'X') dfs(blockhouse,Point(pos.first,pos.second+1),sum);
        else{
            if(check(blockhouse, pos)) {
                blockhouse[pos.first][pos.second] ='*';
                dfs(blockhouse,Point(pos.first,pos.second+1),sum+1);
                blockhouse[pos.first][pos.second] = '.';
            }
            dfs(blockhouse,Point(pos.first,pos.second+1),sum);
        }
    }
    
    int main(){
        int n;
        while(cin >> n && n){
            vector<string> blockhouse(n);
            for(int i = 0; i < n ; ++ i) cin >>  blockhouse[i];
            ans = 0;
            dfs(blockhouse,Point(0,0),0);
            cout<< ans<<endl;
    
        }
    }
  • 相关阅读:
    2017.11.10 MPLAB IPE + ICD-3+ PIC32MM
    How to Have a Healthy Relationship --shanbei 为单身节写
    New Concept English three (35)
    PyQt(Python+Qt)学习随笔:Qt Designer中主窗口对象的dockOptions属性
    PyQt(Python+Qt)学习随笔:Qt Designer中主窗口对象unifiedTitleAndToolBarOnMac属性
    PyQt(Python+Qt)学习随笔:Qt Designer中主窗口对象dockNestingEnabled属性
    PyQt(Python+Qt)学习随笔:Qt Designer中主窗口对象的tabShape属性
    PyQt(Python+Qt)学习随笔:Qt Designer中主窗口对象documentMode属性
    PyQt(Python+Qt)学习随笔:Qt Designer中主窗口对象的toolButtonStyle属性
    PyQt(Python+Qt)学习随笔:Qt Designer中主窗口对象的animated属性
  • 原文地址:https://www.cnblogs.com/xiongqiangcs/p/3692032.html
Copyright © 2011-2022 走看看