zoukankan      html  css  js  c++  java
  • 【ACM】hdu_1004_Let the Balloon Rise

    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 57556    Accepted Submission(s): 21037


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    5
    green
    red
    blue
    red
    red
    3
    pink
    orange
    pink
    0
     
    Sample Output
    red
    pink

    hdu_1004_Let the Balloon Rise_201307271045.c

    #include <stdio.h>
    #include <string.h>
    int main()
    {
     char str[1010][18];
     int n;
     while(scanf("%d",&n),n)
     {
     int i,j,k,m=0,num=0;
     char str1[18],str2[18];
     for(i=0;i<n;i++)
     {
      gets(str[i]);
     }
     for(j=1;j<n;j++)
     for(i=0;i<n-j;i++)
     if(strcmp(str[i],str[i+1])>0)
     {
      strcpy(str1,str[i]);
      strcpy(str[i],str[i+1]);
      strcpy(str[i+1],str1);
     }
     strcpy(str2,str[0]);
        for(i=0;i<n;i++)
        {
         if(strcmp(str2,str[i])==0)
         num++;
         else
         {
          strcpy(str2,str[i]);
          num=1;
          if(num>m)
          {
             m=num;
            
             k=i-1;
          }
         }
        }
        if(num>m)
        {
         m=num;        
            k=i-1;
        }
        printf("%s ",str[k]);
     }       
     return 0; 
    }

    //超时

    //参考代码如下:

    #include <stdio.h>
    #include <string.h>
    main(){
        int n, i, j, t, max, num[1000];
        char color[1000][16];
        while(scanf("%d", &n) != EOF){
            if(n){
                num[0]=0;
                scanf("%s", color[0]);
                for(i=1; i <n; i++){
                    num[i]=0;
                    scanf("%s", color[i]);
                    for(j=0; j <i-1; j++)
                        if(strcmp(color[i], color[j])==0) num[i] +=1;
                }
                max=num[0];
                t=0;
                for(i=1; i <n; i++)
                   if(max <num[i]) {max =num[i]; t=i;}
                printf("%s ",color[t]);
            }
        }
    }

    //
     
    改后代码:
    #include <stdio.h>
    #include <string.h>
    int main()
    {
     char str[1010][18]; 
     int n;
     while(scanf("%d",&n),n)
     {
      int i,j,k,max;
      int num[1010]={0};
      k=max=0;
      for(i=0;i<n;i++)
      {
       scanf("%s",str[i]);
       for(j=0;j<i;j++)
       if(strcmp(str[i],str[j])==0)
       num[i]++;   
       if(num[i]>max)
       {
        max=num[i];
        k=i;
       }
      }
      printf("%s ",str[k]);
     }
     return 0;
    }
  • 相关阅读:
    Git`s Operation
    从volatile说到,i++原子操作,线程安全问题
    sql中的几种删除方式
    Hibernate&MyBatis different
    集合问答
    Data Struct and Data Type
    Hash table and application in java
    idea`s shortcut key
    001--idea第一个报错JNI报错
    recyclebin
  • 原文地址:https://www.cnblogs.com/xl1027515989/p/3219233.html
Copyright © 2011-2022 走看看