zoukankan      html  css  js  c++  java
  • 【ACM】hdu_zs3_1005_String Matching_201308100920

    String Matching
    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
    Total Submission(s) : 23   Accepted Submission(s) : 7
    Problem Description
    It's easy to tell if two words are identical - just check the letters. But how do you tell if two words are almost identical? And how close is "almost"?

    There are lots of techniques for approximate word matching. One is to determine the best substring match, which is the number of common letters when the words are compared letter-byletter.

    The key to this approach is that the words can overlap in any way. For example, consider the words CAPILLARY and MARSUPIAL. One way to compare them is to overlay them:

    CAPILLARY
    MARSUPIAL

    There is only one common letter (A). Better is the following overlay:

    CAPILLARY
         MARSUPIAL
    with two common letters (A and R), but the best is:

       CAPILLARY
    MARSUPIAL
    Which has three common letters (P, I and L).

    The approximation measure appx(word1, word2) for two words is given by:

    common letters * 2
    -----------------------------
    length(word1) + length(word2)

    Thus, for this example, appx(CAPILLARY, MARSUPIAL) = 6 / (9 + 9) = 1/3. Obviously, for any word W appx(W, W) = 1, which is a nice property, while words with no common letters have an appx value of 0.
     

    Input
    The input for your program will be a series of words, two per line, until the end-of-file flag of -1.
    Using the above technique, you are to calculate appx() for the pair of words on the line and print the result.
    The words will all be uppercase.
     

    Output
    Print the value for appx() for each pair as a reduced fraction,Fractions reducing to zero or one should have no denominator.
     

    Sample Input
    CAR CART
    TURKEY CHICKEN
    MONEY POVERTY
    ROUGH PESKY
    A A
    -1

    Sample Output
    appx(CAR,CART) = 6/7
    appx(TURKEY,CHICKEN) = 4/13
    appx(MONEY,POVERTY) = 1/3
    appx(ROUGH,PESKY) = 0
    appx(A,A) = 1

    Source
    PKU

    #include <stdio.h>
    #include <string.h>
    #define MAX 1000

    char str1[MAX];
    char str2[MAX];

    int common(int i,int j,int len1,int len2)
    {
     int k=0;
     for(;i<len1;i++)
     {
      if(str1[i]==str2[j])
      k++;
            j++;
      if(j>=len2) break;
     }
     return k;
    }
    int gcd(int a,int b)
    {
     int t=1;
     while(t)
     {
      t=b%a;
      b=a;
      a=t;
     }
     return b; 
    }
    int main()
    {
     while(scanf("%s",str1)&&(strcmp(str1,"-1")!=0))
     {
      int i,j,k,t,len1,len2,num;
      scanf("%s",str2);
      len1=strlen(str1);
      len2=strlen(str2);
      num=t=k=0;
      for(i=0;i<len1;i++)
      {
       for(j=0;j<len2;j++)
       {
        if(str1[i]==str2[j])
        {
         t=common(i,j,len1,len2);
         if(t>num)
         {num=t;t=0;}
         break;
        }
       }
      }
      if(num==0)
      printf("appx(%s,%s) = 0 ",str1,str2);
      else if(num*2==len1+len2)
      printf("appx(%s,%s) = 1 ",str1,str2);
      else
      {
      k=gcd(num*2,len1+len2);
      printf("appx(%s,%s) = %d/%d ",str1,str2,num*2/k,(len1+len2)/k);
      }
      //k=gcd(12,54);
      //printf("%d ",k);
      //puts(str1);
      //puts(str2);
     }
     return 0;
    }

  • 相关阅读:
    二叉树知识拓展
    【2014年鄞州区】小幸福(e.pas/c/cpp)
    【2017年常州市】小X与队列 (queue)
    【2018年南海区甲组】扑克游戏(poker)
    【2018年南海区甲组】拆除桥墩(remove)
    【NOIP普及组模拟赛3】投影(skyline)
    常用正则表达式
    asp.net访问母版页控件方法
    C#文件读写操作
    C#读取csv格式文件
  • 原文地址:https://www.cnblogs.com/xl1027515989/p/3253869.html
Copyright © 2011-2022 走看看