zoukankan      html  css  js  c++  java
  • POJ 1700 F(Contest #3)

    Description

    A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

    Input

    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

    Output

    For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

    Sample Input

    1
    4
    1 2 5 10
    

    Sample Output

    17

    #include <iostream>
    #include <algorithm>
    using namespace std;

    int main()
    {
      freopen("in.txt","r",stdin);
      int speed[1000];

      int t,n,time;
      cin>>t;
      int i,j;
      for(i=0;i<t;i++)
      {
        cin>>n;
        memset(speed,0,sizeof(speed));
        for(j=0;j<n;j++)cin>>speed[j];
          sort(speed,speed+n); //从小到大排序
        time=0;
        while(n>3)
        {
          if(speed[1]*2 > speed[0]+speed[n-2])
          time=time+speed[0]+speed[0]+speed[n-1]+speed[n-2];
          else time=time+speed[1]+speed[0]+speed[n-1]+speed[1];
          n=n-2;
        }
        if(n==3)
        time=time+speed[0]+speed[1]+speed[2];
        else if(n==2)
        time=time+speed[1];
        else if(n==1)
        time=time+speed[0];
        cout<<time<<endl;
        }
    return 0;
    }

  • 相关阅读:
    windows 10 安装可视化mycat
    YYModel 源码解读(二)之NSObject+YYModel.h (1)
    NSCharacter​Set 使用说明
    YYModel 源码解读(二)之YYClassInfo.h (3)
    Cocoa深入学习:NSOperationQueue、NSRunLoop和线程安全 (转)
    Swift 必备开发库 (高级篇) (转)
    YYModel 源码解读(二)之YYClassInfo.h (2)
    YYModel 源码解读(二)之YYClassInfo.h (1)
    Runtime应用防止按钮连续点击 (转)
    YYModel 源码解读(一)之YYModel.h
  • 原文地址:https://www.cnblogs.com/xl1164191281/p/4659810.html
Copyright © 2011-2022 走看看