zoukankan      html  css  js  c++  java
  • POJ 1700 F(Contest #3)

    Description

    A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

    Input

    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

    Output

    For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

    Sample Input

    1
    4
    1 2 5 10
    

    Sample Output

    17

    #include <iostream>
    #include <algorithm>
    using namespace std;

    int main()
    {
      freopen("in.txt","r",stdin);
      int speed[1000];

      int t,n,time;
      cin>>t;
      int i,j;
      for(i=0;i<t;i++)
      {
        cin>>n;
        memset(speed,0,sizeof(speed));
        for(j=0;j<n;j++)cin>>speed[j];
          sort(speed,speed+n); //从小到大排序
        time=0;
        while(n>3)
        {
          if(speed[1]*2 > speed[0]+speed[n-2])
          time=time+speed[0]+speed[0]+speed[n-1]+speed[n-2];
          else time=time+speed[1]+speed[0]+speed[n-1]+speed[1];
          n=n-2;
        }
        if(n==3)
        time=time+speed[0]+speed[1]+speed[2];
        else if(n==2)
        time=time+speed[1];
        else if(n==1)
        time=time+speed[0];
        cout<<time<<endl;
        }
    return 0;
    }

  • 相关阅读:
    Deno下一代Nodejs?Deno初体验
    2018年JavaScript现状报告
    国企程序员是一种怎样的体验
    前端面试送命题(二)-callback,promise,generator,async-await
    Nodejs mongoose 详解
    JS的进阶技巧
    Nodejs经验谈
    给腾讯云Linux主机创建Swap文件
    LVS跨网段DR模式并使用ldirectord实现RS高可用性
    LAMP配置NFS页面共享,autofs实现挂载,DNS实现名称解析,纯手动操作
  • 原文地址:https://www.cnblogs.com/xl1164191281/p/4659810.html
Copyright © 2011-2022 走看看