zoukankan      html  css  js  c++  java
  • hdoj1004--Let the Balloon Rise

    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    5
    green
    red
    blue
    red
    red
    3
    pink
    orange
    pink
    0
     
    Sample Output
    red
    pink
     
    使用C++ STL中的map模板
    #include<iostream>
    #include<cstdio>
    #include<map>
    #include<string>
    #include<cstring>
    using namespace std;
    
    void solve()
    {
        int T, max, t;
        map<string, int> color_count;
        string color;
        while(cin>>T && T) {
            max = 0;
            while(T--) {
                cin>>color;
                ++color_count[color];
            }
            map<string, int>::const_iterator ii, it;
            it = color_count.begin();
            while(it != color_count.end()) {
                if(max < it->second) {
                    max = it->second;
                    ii = it;
                }
                it++;
            }
            cout<<ii->first<<endl;
            color_count.clear();
        }
    }
    
    int main()
    {     
        solve();
        return 0;
    }
  • 相关阅读:
    BADI 笔记
    ALV 常用功能 转载
    F4字段搜索帮助
    全省各地均可拨打劳动违法投诉电话:12333
    小结SQL Server连接失败错误及解决
    sql server日志已满处理方法
    VC6.0快捷键大全
    Eclipse下UML插件及安装
    Delphi错误:"External exception C0000235"
    delphi中临界操作方法
  • 原文地址:https://www.cnblogs.com/xueda120/p/3573977.html
Copyright © 2011-2022 走看看