zoukankan      html  css  js  c++  java
  • hdu1087 简单DP

    I - 简单dp 例题扩展

    Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

    Submit Status

    Description

    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
    Your task is to output the maximum value according to the given chessmen list.
     

    Input

    Input contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
    A test case starting with 0 terminates the input and this test case is not to be processed.
     

    Output

    For each case, print the maximum according to rules, and one line one case.
     

    Sample Input

    3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
     

    Sample Output

    4 10 3
    思路分析:简单DP,状态转移方程if(a[i]>a[j]) dp[i]=max(dp[i],a[i]+dp[j])
    代码:
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    #include <queue>
    #include <stack>
    using namespace std;
    const int maxn=1000+100;
    int dp[maxn],a[maxn];
    const int inf=0xfffffff;
    int main()
    {
        int n;
        while(scanf("%d",&n)!=EOF&&n)
        {
            memset(dp,0,sizeof(dp));
            for(int i=1;i<=n;i++)
                scanf("%d",&a[i]);
            dp[1]=a[1];
            int ma=-inf;
            for(int i=2;i<=n;i++)
            {
                dp[i]=a[i];
                for(int j=i-1;j>=1;j--)
                {
                    if(a[i]>a[j])
                    dp[i]=max(dp[i],a[i]+dp[j]);
                }
                if(dp[i]>ma)
                    ma=dp[i];
            }
            cout<<ma<<endl;
        }
        return 0;
    }
  • 相关阅读:
    vue监听多个变量的方法
    Unicode与JavaScript详解
    两个数组合并的方法
    第13章 事件
    第12章 DOM2和DOM3
    IIS发布WebService的一些常见问题
    Openlayers修改矢量要素并且可捕捉
    Openlayers修改矢量要素
    openlayers画图形返回范围
    前台html与后台php通信(上传文件)
  • 原文地址:https://www.cnblogs.com/xuejianye/p/5476231.html
Copyright © 2011-2022 走看看