zoukankan      html  css  js  c++  java
  • poj1083 贪心

    K - 简单dp

    Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

    Submit Status

    Description

    The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

    The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

    For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

    Input

    The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
    Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
    line, the remaining test cases are listed in the same manner as above.

    Output

    The output should contain the minimum time in minutes to complete the moving, one per line.

    Sample Input

    3 
    4 
    10 20 
    30 40 
    50 60 
    70 80 
    2 
    1 3 
    2 200 
    3 
    10 100 
    20 80 
    30 50 
    

    Sample Output

    10
    20
    30
    题目大意:有400个房屋,需要在这些房屋之间搬运箱子,但是同一段走廊在每10分钟只能进行一次搬运,问你最少要多少分钟才能完成搬运任务。
    思路分析:我看题目分类这道题是划分在dp里面的,刚开始一直想构造状态转移方程,就是没有弄出来,后来看了别人的题解,才造用贪心做,直接
    记录每个区间的访问次数,访问最大次数*10就是需要的最短时间。
    代码:
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    #include <queue>
    #include <stack>
    #define mem(a) memset(a,0,sizeof(a))
    using namespace std;
    const int maxn=400+10;
    const int inf=0xffffff;
    int t[maxn];
    int main()
    {
         int T,n,a,b;
         cin>>T;
         while(T--)
         {
             scanf("%d",&n);
             mem(t);
             int ma=-inf;
             for(int i=0;i<n;i++)
             {
                 scanf("%d%d",&a,&b);
                 if(a>b) swap(a,b);
                 if(a%2==0) a--;
                 if(b%2==1) b++;
                 for(int j=a;j<=b;j++)
                   t[j]++;
             }
             for(int i=1;i<=400;i++)
             {
                 ma=max(ma,t[i]);
             }
             cout<<10*ma<<endl;
         }
        return 0;
    }
  • 相关阅读:
    Object C语法学习
    iOS9的几个新关键字(nonnull、nullable、null_resettable、__null_unspecified)
    系统迭代新功能及第三方技术
    码云&Github 个人代码资源快速查找
    iOS开发应用结构化资源储备
    新增扩展程序功能打包提交新版 WARNING ITMS-90473 警告问题
    NSRect 位置和尺寸
    iOS应用打包完后再在开发者网站添加应用测试ID能够加入测试吗
    苹果原生文字转语音播报
    SiriShortCut模型建立及数据交互逻辑
  • 原文地址:https://www.cnblogs.com/xuejianye/p/5483245.html
Copyright © 2011-2022 走看看