zoukankan      html  css  js  c++  java
  • hdu4006 优先队列

    A - 签到

    Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:65768KB     64bit IO Format:%I64d & %I64u

    Description

    Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
     

    Input

    There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.
     

    Output

    The output consists of one integer representing the largest number of islands that all lie on one line.
     

    Sample Input

    8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
     

    Sample Output

    1 2 3

    HintXiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
    题目大意:

    有n步操作,I代表往这一串数里面再加一个,Q则代表查询第k大的数是哪一个。

    思路分析:首先要明白第k大的数实际上就是有k-1个数比他大,另外数据范围很大,直接暴力肯定TLE,

    因此可以想到使用优先队列这种数据结构,构造最小堆,堆顶的元素刚好是第k大的数,因此当q.size()>k时

    直接pop(),避免爆内存。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    #include <queue>
    #include <stack>
    #include <vector>
    using namespace std;
    int main()
    {
        int n,k,m;
        char s[5];
        while(scanf("%d%d",&n,&k)!=EOF)
        {
            priority_queue<int,vector<int>,less<int> >Q;
            while(n--)
            {
                scanf("%s",s);
                 if(s[0]=='I')
                 {
                        scanf("%d",&m);
                        Q.push(m);
                        if(Q.size()>k) Q.pop();
                 }
                else
                {
                    printf("%d ",Q.top());
                }
            }
        }
        return 0;
    }

     

  • 相关阅读:
    08-30 作业整理
    JS题目整理
    08-20作业整理
    CSS3知识总结
    CSS样式表知识总结
    html标签知识总结
    Dice (III) 概率dp
    Island of Survival 概率
    How far away ?
    Hdu 2874 Connections between cities
  • 原文地址:https://www.cnblogs.com/xuejianye/p/5572679.html
Copyright © 2011-2022 走看看