zoukankan      html  css  js  c++  java
  • 快速切题 poj1573

    Robot Motion
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 10708   Accepted: 5192

    Description


    A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

    N north (up the page) 
    S south (down the page) 
    E east (to the right on the page) 
    W west (to the left on the page) 

    For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

    Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

    You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

    Input

    There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

    Output

    For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

    Sample Input

    3 6 5
    NEESWE
    WWWESS
    SNWWWW
    4 5 1
    SESWE
    EESNW
    NWEEN
    EWSEN
    0 0 0

    Sample Output

    10 step(s) to exit
    3 step(s) before a loop of 8 step(s)
    题意:一个迷宫,机器人从某行最上方进入,跟随每一步到达的迷宫的指示行动,问机器人是否能到达迷宫外(任意一边都可以出),或者会在何时进入圈
    应用时:15min
    实际用时:51min
    原因:读题,x,y用反
    #define ONLINE_JUDGE
    #include<cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    
    int A,B,sx,sy;
    char maz[101][101];
    int vis[101][101];
    const int dx[4]={0,1,0,-1};
    const int dy[4]={-1,0,1,0};
    
    int dir(char ch){
        if(ch=='N')return 0;
        else if(ch=='E')return 1;
        else if(ch=='S')return 2;
        return 3;
    }
    void solve(){
        memset(vis,0,sizeof(vis));
        sx--;sy=0;
        int step=0;
        int fx,fy;
        while(!vis[sy][sx]&&sx>=0&&sx<A&&sy>=0&&sy<B&&++step){
            fx=sx;fy=sy;
            vis[sy][sx]=step;
            sx=dx[dir(maz[fy][fx])]+fx;
            sy=dy[dir(maz[fy][fx])]+fy;
        }
        if(sx<0||sy<0||sx>=A||sy>=B)printf("%d step(s) to exit\n",step);
        else {
            printf("%d step(s) before a loop of %d step(s)\n",vis[sy][sx]-1,step+1-vis[sy][sx]);
        }
    }
    int main(){
        #ifndef ONLINE_JUDGE
            freopen("output.txt","w",stdout);
        #endif // ONLINE_JUDGE
        while(scanf("%d%d%d",&B,&A,&sx)==3&&A&&B){
    
            for(int i=0;i<B;i++)scanf("%s",maz[i]);
            solve();
        }
        return 0;
    }
    

      

  • 相关阅读:
    pins-模块内的代码及资源隔离方案
    Android Gradle defaultConfig详解及实用技巧
    实用抓包工具:whistle
    Gradle中的闭包
    Android Gradle 依赖配置:implementation & api
    Android Studio Run项目出现Failure [INSTALL_FAILED_TEST_ONLY]
    Android 8.0对隐式广播的进一步限制
    cookie 详解
    一分钟内搭建全web的API接口神器json-server详解
    高性能前端 art-template 模板
  • 原文地址:https://www.cnblogs.com/xuesu/p/3944259.html
Copyright © 2011-2022 走看看