zoukankan      html  css  js  c++  java
  • HDU 4791 Alice's Print Service 思路,dp 难度:2

    A - Alice's Print Service
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

    Description

    Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money. 
    For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents. 
    Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
     

    Input

    The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow. 
    Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 10 5 ). The second line contains 2n integers s 1, p 1 , s 2, p2 , ..., s n, p n (0=s 1 < s 2 < ... < s n ≤ 10 9 , 10 9 ≥ p 1 ≥ p 2 ≥ ... ≥ p n ≥ 0).. The price when printing no less than s i but less than s i+1 pages is p i cents per page (for i=1..n-1). The price when printing no less than s n pages is p n cents per page. The third line containing m integers q 1 .. q m (0 ≤ q i ≤ 10 9 ) are the queries.
     

    Output

    For each query q i, you should output the minimum amount of money (in cents) to pay if you want to print q i pages, one output in one line.
     

    Sample Input

    1 2 3 0 20 100 10 0 99 100
     

    Sample Output

    0 1000 1000
     思路:稍微拿多一点可能更便宜
    #include <cstdio>
    #include <cstdlib>
    #include <algorithm>
    #include <vector>
    #include <iostream>
    #define INF 1e18
    using namespace std;
    
    const int maxn=100500;
    
    typedef long long LL;
    
    LL s[maxn],p[maxn],h[maxn];
    
    int main()
    {
    	int T,n,m;
    	LL mid,mmin,res;
    	scanf("%d",&T);
    	while(T--){
    		scanf("%d%d",&n,&m);
    		for(int i=0;i<n;i++){
    			scanf("%I64d%I64d",&s[i],&p[i]);
    			h[i]=s[i]*p[i];
    		}
    		mmin=INF;
    		for(int i=n-1;i>=0;i--){
    			mmin=min(s[i]*p[i],mmin);
    			h[i]=mmin;
    		}
    		for(int kk=0;kk<m;kk++){
    			scanf("%I64d",&mid);
    			if(mid>=s[n-1]) printf("%I64d\n",mid*p[n-1]);
    			else{
                    int t=upper_bound(s,s+n,mid)-s;
                    res=mid*p[t-1];
                    res=min(res,h[t]);
                    printf("%I64d\n",res);
    			}
    		}
    	}
    	return 0;
    }
    

      

  • 相关阅读:
    人物装备的选取
    状压 + 背包
    村庄之间建立邮局
    woj
    括号匹配算面积(模拟)
    流程控制之if
    周末练习题(第一周)
    day04作业
    流程控制之for
    Python流程控制之while
  • 原文地址:https://www.cnblogs.com/xuesu/p/3979851.html
Copyright © 2011-2022 走看看