zoukankan      html  css  js  c++  java
  • hdu4800 Josephina and RPG 解题报告

    Josephina and RPG

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 511    Accepted Submission(s): 139
    Special Judge


    Problem Description
    A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of characters in a fictional setting. Players take responsibility for acting out these roles within a narrative, either through literal acting or through a process of structured decision-making or character development.
    Recently, Josephina is busy playing a RPG named TX3. In this game, M characters are available to by selected by players. In the whole game, Josephina is most interested in the "Challenge Game" part.
    The Challenge Game is a team play game. A challenger team is made up of three players, and the three characters used by players in the team are required to be different. At the beginning of the Challenge Game, the players can choose any characters combination as the start team. Then, they will fight with N AI teams one after another. There is a special rule in the Challenge Game: once the challenger team beat an AI team, they have a chance to change the current characters combination with the AI team. Anyway, the challenger team can insist on using the current team and ignore the exchange opportunity. Note that the players can only change the characters combination to the latest defeated AI team. The challenger team gets victory only if they beat all the AI teams.
    Josephina is good at statistics, and she writes a table to record the winning rate between all different character combinations. She wants to know the maximum winning probability if she always chooses best strategy in the game. Can you help her?
     
    Input
    There are multiple test cases. The first line of each test case is an integer M (3 ≤ M ≤ 10), which indicates the number of characters. The following is a matrix T whose size is R × R. R equals to C(M, 3). T(i, j) indicates the winning rate of team i when it is faced with team j. We guarantee that T(i, j) + T(j, i) = 1.0. All winning rates will retain two decimal places. An integer N (1 ≤ N ≤ 10000) is given next, which indicates the number of AI teams. The following line contains N integers which are the IDs (0-based) of the AI teams. The IDs can be duplicated.
     
    Output
    For each test case, please output the maximum winning probability if Josephina uses the best strategy in the game. For each answer, an absolute error not more than 1e-6 is acceptable.
     
    Sample Input
    4 0.50 0.50 0.20 0.30 0.50 0.50 0.90 0.40 0.80 0.10 0.50 0.60 0.70 0.60 0.40 0.50 3 0 1 2
     
    Sample Output
    0.378000

     坑点: 有可能超过c(m,3),忽略可A

    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    #include <iostream>
    #define INF 10000005000
    using namespace std;
    
    const int maxm=10500;
    const int maxn=150;
    
    typedef long long LL;
    
    int c[20][20],a[maxm];
    double dp[2][maxn];
    double cc[maxn][maxn];
    
    void init()
    {
    	memset(c,0,sizeof(c));
    	c[0][0]=c[1][0]=c[1][1]=1;
    	for(int i=2;i<=15;i++){
    		c[i][0]=c[i][i]=1;
    		for(int j=1;j<i;j++) c[i][j]=(c[i-1][j]+c[i-1][j-1]);
    	}
    }
    
    int main()
    {
    	int N,n,M,cur;
    	double res;
    	init();
    	while(scanf("%d",&N)!=EOF){
    		n=c[N][3];
    		for(int i=0;i<n;i++) for(int j=0;j<n;j++) scanf("%lf",&cc[i][j]);
    		memset(dp,0,sizeof(dp));
    		scanf("%d",&M);
    		for(int i=0;i<M;i++) {scanf("%d",&a[i]);if(a[i]>n)a[i]=0;}//ATTENTION!
    	    for(int i=0;i<n;i++) dp[0][i]=cc[i][a[0]];
    	    cur=1;
    	    for(int i=1;i<M;i++){
    	    	for(int j=0;j<n;j++) dp[cur][j]=0;
    	    	for(int j=0;j<n;j++){
    	    		dp[cur][j]=max(dp[cur][j],dp[cur^1][j]*cc[j][a[i]]);
    	    		dp[cur][a[i-1]]=max(dp[cur][a[i-1]],dp[cur^1][j]*cc[a[i-1]][a[i]]);
    	    	}
    	    	cur^=1;
    	    }
    	    res=0;
    	    for(int i=0;i<n;i++) res=max(res,dp[cur^1][i]);
    	    printf("%.6f\n",res);
    	}
    }
  • 相关阅读:
    数据库的存储过程、数据库设计范式、数据库关系
    谈谈窗体之间的数据交互
    hdu2141AC代码分享
    参考C++STL标准库中对了的使用方法
    背包类问题解答——poj3624分析
    ACM第一天研究懂的AC代码——BFS问题解答——习题zoj2165
    洛谷——P2483 [SDOI2010]魔法猪学院
    洛谷——P2822 组合数问题
    COGS——T 2739. 凯伦和咖啡
    洛谷—— P3225 [HNOI2012]矿场搭建
  • 原文地址:https://www.cnblogs.com/xuesu/p/3979853.html
Copyright © 2011-2022 走看看